Plaats van button op formulier wijkt af van design

gevraagd 2019-12-28 17:24:55 +0100

Tom Kuipers gravatar image

updated 2019-12-28 22:52:35 +0100

Wanneer ik een of meer buttons op een form plaats in edit-mode verschijnen deze in display-mode opeens ergens anders. Op bijgevoegde screenshots is dit visueel gemaakt. C:\fakepath\Screenshot-as-displayed.jpg C:\fakepath\Screenshot-as-editted.jpg Kan dit mogelijk te maken hebben dat er "onder" de betreffende button ook een rechthoek (als "shape") aanwezig is? Wanneer ik deze echter verwijder blijft het probleem bestaan.

Het gebeurd soms ook tijdens het openen van een formulier, dat een textbox of een button op een verkeerde plaats wordt getoond, maar een volgende keer is alles weer zoals tijdens design is vastgelegd. Ben benieuwd of er meer ervaringen (en oplossingen) zijn m.b.t. dit fenomeen.

bewerken retag markeer ongewenst sluiten samenvoegen verwijderen

Commentaren

Nog niet eerder gezien, maar een knop wordt standaard verankerd aan een alinea.... Misschien dat het een bug is.

rwestein gravatar imagerwestein ( 2019-12-31 16:18:44 +0100 )bewerken

Alle knoppen en textboxen zijn verankerd aan pagina. Wel gebruik ik een macro om de grootte en plaats van verschillende formulieren bij het openen te bepalen, maar of dat ermee te maken heeft lijkt mij minder waarschijnlijk. Ook heb ik ge-experimenteerd met het invoegen van Wait xxx op verschillende plaatsen, maar dat lijkt ook niet te helpen.....

Tom Kuipers gravatar imageTom Kuipers ( 2020-01-05 13:28:50 +0100 )bewerken

Verder een aantal testen uitgevoerd, waarbij het volgende is opgevallen: Het lijkt erop dat de verschillen in grootte van verschillende formulieren er inderdaad mee te maken heeft.

  1. In mijn toepassing sluit ik eerst het vorige formulier (d.m.v. een macro) en open daarna het andere.

  2. Bij het openen van een formulier wordt een macro aangeroepen die de window-grootte bepaalt.

  3. Wanneer het zojuist gesloten window KLEINER was dan het te openen formulier-window doet zich dit fenomeen zich voor. Wanneer hetzelfde formulier opnieuw wordt aangeroepen (switchboard) staat ook alles weer goed, maar dan wordt ook eerst het betreffende formulier eerst gesloten en opnieuw ge-opend.

  4. Wanneer ik de window-groottes aan elkaar gelijk maakt doet zicht het probleem(pje) NIET voor. Graag advies!

Tom Kuipers gravatar imageTom Kuipers ( 2020-01-08 15:19:50 +0100 )bewerken