We will be migrating from Ask to Discourse on the first week of August, read the details here

Stel uw vraag
0

java opties JRE's - Mac OS

gevraagd 2020-10-18 11:40:27 +0200

BenvdH gravatar image

Op mijn MacBook Air is JRT versie 1.8.261.12 geïnstalleerd. De locatie is bibliotheek/internet Plug-ins/JavaAppletPlugin.plugin.

Het lukt mij niet om hiernaar te verwijzen bij Voorkeuren/Geavanceerd omdat die JavaAppletPlugin (blijkbaar) een pakket is waarvan ik de onderliggende mappen via deze weg niet te zien krijg, dus ook niet kan kiezen.

Als ik in Finder op de AppletPlugin sta kan ik kiezen voor "Toon pakketinhoud" en dan kan ik de onderliggende mappen wel zien.

Ik heb OpenOffice van Appache maar weer eens geïnstalleerd en die vindt zonder enig probleem in Voorkeuren/Java de locatie /library/Internet Plug-ins/JavaAppletPlugin.plungin/Contents/home

Suggesties??

bewerken retag markeer ongewenst sluiten samenvoegen verwijderen

Commentaren

Is je vraag beantwoord? Klik dan op ✓ naast het goede antwoord en sluit vervolgens je vraag. Klik op ^ naast antwoorden waar je wat aan had. Stem wanneer je nuttige informatie vindt. Daarmee help je de AskLibO-gemeenschap. Voor meer informatie, zie de helpfunctie rechtsboven.

Piscatorius gravatar imagePiscatorius ( 2021-02-16 13:40:59 +0200 )bewerken

2 Antwoorden

1

beantwoord 2020-10-18 19:02:19 +0200

Piscatorius gravatar image

De Java applet plug-in is bedoeld voor het gebruik in de browser. Daarom staat hij ook in de map met internet plug-ins. Voor LibreOffice heb je daar helaas niets aan.

Wil je Java in LibreOffice gebruiken op een Mac met macOS 10.10 of nieuwer dan heb je ook geen JRE nodig, maar een JDK (zie daarvoor: https://wiki.documentfoundation.org/F...).

Of je nou kiest voor de JDK van Oracle of OpenJDK van bijvoorbeeld AdoptOpenJDK (https://wiki.documentfoundation.org/F...), de JDK zal altijd terechtkomen in de volgende map: /Library/Java/JavaVirtualMachines.

Om een extensie als LanguageTool in LibreOffice te gebruiken heb je op een Mac echter ook nog Java voor OS X nodig (zie daarvoor: https://languagetool.org/issues en vervolgens https://support.apple.com/kb/DL1572?l...).

bewerken markeer ongewenst verwijderen link meer
0

beantwoord 2020-10-20 14:07:57 +0200

BenvdH gravatar image

Dank @Piscatorius, ik heb opnieuw JDK 15 geïnstalleerd en daarna ook LibreOffice 7.0 weer opnieuw geïnstalleerd. LibreOffice ziet in Voorkeuren/Geavanceerd JDK wel, maar blijft bij het aanmaken van een tabel in Base de volgende melding geven:

"LibreOffice vereist een Java Runtime Environment (JRE) om deze taak uit te voeren. De geselecteerde JRE is defect. Selecteer een andere versie of installeer een nieuwe JRE en selecteert u deze onder LibreOffice - Voorkeuren - LibreOffice - Geavanceerd.

Ik heb al gezien dat hier al heel veel topics over gaan. Ik vermoed dat het iets eigenaardigs in OS X is, ik laat het voorlopig maar even rusten...

bewerken markeer ongewenst verwijderen link meer

Commentaren

Het klopt, onder macOS heeft LibreOffice 7.0 inderdaad een probleem met Java, waardoor er een foutmelding verschijnt dat de geselecteerde JRE defect zou zijn. Het probleem is echter bekend en er wordt gewerkt aan een oplossing. Deze zal naar het schijnt echter pas beschikbaar komen in LibreOffice 7.1.0 (zie daarvoor: https://bugs.documentfoundation.org/s...).

Tot die tijd verdient het aanbeveling om in plaats van voor de Fresh (LibreOffice 7.0.2) gewoon voor de Still (LibreOffice 6.4.6) te gaan. De laatste hoofdversie (Fresh) is voor gebruikers die uit zijn op de nieuwste verbeteringen en toevoegingen, terwijl de voorlaatste versie (Still) meer bestemd is voor gebruikers die een hoge stabiliteit verkiezen boven de nieuwste wijzigingen.

Vanwege het Java-probleem werk ikzelf bijvoorbeeld nog steeds met LibreOffice 6.4.6, omdat ik anders geen gebruik zou kunnen maken van de extensie LanguageTool.

Piscatorius gravatar imagePiscatorius ( 2020-10-20 18:18:30 +0200 )bewerken

Goed nieuws, BenvdH! Vandaag is LibreOffice 7.0.4 uitgekomen. Deze versie bevat een patch voor bug tdf#135479(zie daarvoor: https://wiki.documentfoundation.org/R...). De oplossing voor het bovengenoemde Java-probleem zou eigenlijk pas beschikbaar komen in LibreOffice 7.1.0, maar met dank aan Tor Lillqvist is de patch nu al in de officiële release verwerkt. Ik heb LibreOffice 7.0.4 intussen geïnstalleerd en kan bevestigen dat de patch werkt.

Piscatorius gravatar imagePiscatorius ( 2020-12-17 20:00:36 +0200 )bewerken
Login/Registreer om te beantwoorden

Hulpmiddelen Vragen

1 volger

Statistieken

Gevraagd: 2020-10-18 11:40:27 +0200

Bekeken: 92 keer

Laatst bijgewertkt: Oct 20 '20