Stel uw vraag

Danixu86's profiel - activiteit

2018-04-12 16:25:16 +0200 badge ontvangen  enthousiast
2018-04-06 01:21:13 +0200 bewerkte een vraag Vincular Calc a dbase

Vincular excel a dbase Hola, Estoy haciendo investigación porque me gustaría crear una hoja de cálculo con calc que ten

2018-04-06 01:20:38 +0200 reageerde op een vraag Vincular Calc a dbase

Si, perdona. Es que a veces se me mezcla y digo Excel.

2018-04-06 00:32:19 +0200 reageerde op een antwoord Vincular Calc a dbase

Hola, Gracias por tu respuesta, pero he estado mirando lo de las tablas dinámicas y las veo como un filtro para generar

2018-04-05 22:44:13 +0200 stelde een vraag Vincular Calc a dbase

Vincular excel a dbase Hola, Estoy haciendo investigación porque me gustaría crear una hoja de cálculo con calc que ten

2017-03-19 13:55:33 +0200 badge ontvangen  Taxonomist
2015-10-05 17:41:59 +0200 stelde een vraag Error 522 combinando Macros Basic con funciones

Hola buenas,

Quería preguntaros antes de reportarlo como bug por si acaso era un fallo puntual de mi PC, o algún error que he cometido y no soy capaz de ver.

Resulta que estoy haciendo una hoja de calculo con calc que utiliza macros en basic para realizar ciertas fórmulas, y después utiliza el resultado de esas macros en varias funciones y cálculos básicos de calc (SUMA, 5*8). El problema que me da es que cuando cierro y abro el libreoffice, algunas de esas celdas (que funcionan bien) de repente pasan a contener un error 522.

Parece que hay que reunir ciertos requisitos para que el error ocurra:

  • Que sea una hoja distinta a la primera. Si es la primera funciona perfectamente.
  • Que al abrir, sea en esa hoja. Si se abre el LibreOffice en otra hoja entonces no sale el error.
  • Que tenga varias fórmulas de digamos, "nivel 4", por ejemplo: A1 = Macro, A2 = Macro, A4 = SUMA(A1:A2), A5 = A4*24, y varias con un Mín(A5/4;A5/6)

Este error es aleatorio y no sale siempre en las mismas celdas aunque no modifiques el documento.

Un ejemplo del error es este:

https://mega.nz/#!XsJzGYIK!bbdnP9hA-B...

Prueba de error

Y tiene que tener la combinación de sucesos que digo arriba. Si la hoja es la primera o al abrir el LO abre en otra hoja, no muestra ningún error, y si cuando muestra los errores mueves la hoja de posición, entonces recalcula todo y se quitan.

También si en lugar de usar macros usas fórmulas normales, el error no ocurre.

¿Qué opináis?, ¿es un bug?