Pergunte aqui
0

como fixar area de pesquisa nas funçoes

perguntadas 2017-07-18 20:40:22 +0100

imagem do gravatar de ALSereno

tenho uma planilha que estou preparando uma macro para salvar automático. porem quando vou salvar inserindo uma linha para baixo. As formulas das funções mudam automaticamente deixando área de pesquisa descoberta.

=SEERRO(PROCV(CONCATENAR($C$3;IMOVEL_DADOS.B20;J3;K3);OPER_GERAL.B2:N42;10;0);" ") (inicio)

=SEERRO(PROCV(CONCATENAR($C$3;IMOVEL_DADOS.B20;J3;K3);OPER_GERAL.B6:N46;10;0);" ") ao inserir na planilha open geral as formulas vão alterando.

ANTONIO L. SERENO

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

3 Respostas

0

respondidas 2017-07-19 20:43:56 +0100

imagem do gravatar de Beto

Vá no menu, em Ferramentas, opções, Calc, no item Geral desmarque "Expandir referências quando novas colunas/linhas forem inseridas". Clique em ok.

editar assinalar como ofensivo Excluir Link mais
1

respondidas 2017-07-19 02:22:31 +0100

updated 2017-07-19 02:26:25 +0100

Oi @ALSereno / @João Batista, eu acho mais pratico, nomeando a área de pesquisa:

Selecione a área desejada...

Descrição da imagem

Nomeie a área... digite o nome e de Enter.

Descrição da imagem

E caso queira consultar onde esta a área, clique na setinha...

Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

b. dia obrigado pela sua atenção, porem a área de pesquisa já fiz fixando e ela altera assim mesmo a cada vez que incluo uma nova linha. a forma qual faço e assim gravo um intervalo e depois incluiu uma linha para baixo salvando o conteúdo. (gravação especial c/formatação) ai comecei observar que nas formulas vinculadas a área começam alterar todas. ALSereno

imagem do gravatar de ALSerenoALSereno ( 2017-07-19 15:29:14 +0100 )editar
0

respondidas 2017-07-19 00:51:23 +0100

imagem do gravatar de João Batista

Antonio,

Para fixar o endereço da matriz a ser pesquisada, coloque o sinal de cifrão ($) nas células que identificam a matriz.

Exemplo: OPER_GERAL.$B$6:$N$6

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2017-07-18 20:40:22 +0100

Lidas: 87 vezes

Última atualização: Jul 19 '17