Pergunte aqui
2

Como transformar a palavra "JANEIRO" em 01/01/2017 a 31/01/2017

perguntadas 2017-08-24 17:38:08 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Olá,

Tenho uma planilha onde o usuário deve informar a data de matrícula dos alunos em uma coluna, porém, gostaria de validar as datas inseridas permitindo apenas datas compreendidas entre o primeiro e o último dia do mês que se encontra descrito no início da planilha.

Ou seja, quando o usuário me envia a planilha referente as matrículas de JANEIRO, ele deve, lá no início da planilha, escolher o mês JANEIRO em uma lista suspensa e a mesma coisa com o ano.

Sendo assim, no início da planilha consta a seguinte informação em uma célula "x":

1ªcélula:JANEIRO 2ª célula: 2017

Como fazer utilizando fórmulas para validar datas inseridas na coluna DATA DE MATRÍCULA que estejam compreendidas apenas entre 01/01/2017 a 31/01/2017?

Seria possível fazer isso sem utilizar programação mais avançada?

Desde já, obrigado!

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

0

respondidas 2017-08-25 02:50:29 +0100

updated 2017-08-26 01:05:52 +0100

Segue uma outra alternativa, seguindo o proposto, seleciona-se o mês e o ano e na coluna DATA DE MATRÍCULA somente terá como alternativas, também por escolha, os dias do mês/ano escolhido..

editar assinalar como ofensivo Excluir Link mais

Comentários

1

Obrigado pela resposta Gilberto, apenas não entendi o funcionamento das últimas 4 células do intervalo "datas validas". Aqui eles estão aparecendo sempre com o resultado: #VALOR! Será que fiz algo errado?

imagem do gravatar de GDAEGDAE ( 2017-08-25 15:28:28 +0100 )editar

Ola @GDAE, me desculpe, após planilha pronta dei uma melhorada e esqueci de rever estas formulas. substituas em meu arquivo: em A30 =SE(MÊS(A29+1)=PROCV(Mess;tabmes;2;0);A29+1;""), em A31 =SE(A30="";"";SE(MÊS(A30+1)=PROCV(Mess;tabmes;2;0);A30+1;"")) e em A32 =SE(A31="";"";SE(MÊS(A31+1)=PROCV(Mess;tabmes;2;0);A31+1;"")), ou baixe o Arquivo corrigido

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2017-08-26 01:02:45 +0100 )editar
0

respondidas 2017-08-24 19:46:53 +0100

imagem do gravatar de Beto

updated 2017-08-24 19:54:12 +0100

Sim, vá no menu dados e nomeio um conjunto de células " $Planilha1.$D$1:$D$31 "de uma dada planilha e dê o nome de janeiro. Descrição da imagem

Descrição da imagem

Depois dei selecionada a célula que quer validar e vá em Menu, Validação, em "permitir" escolha "intervalo de células" e em Origem digite "janeiro". E está feito. Mas no caso de que você querer que uma palavra valide em cascata, ou seja seleceionar em uma célula Janeiro para que em outras só apareça determinado conteúdo, recomendo assistir este meu vídeo. Descrição da imagem

editar assinalar como ofensivo Excluir Link mais

Comentários

Aqui, (tinha esquecido de meu artigo) veja em meu blog um arquivo de exemplolo

imagem do gravatar de BetoBeto ( 2017-08-24 21:03:03 +0100 )editar
1

Obrigado Beto! Consultei seu blog também. Tudo bem didático! Valeu!

imagem do gravatar de GDAEGDAE ( 2017-08-25 15:26:48 +0100 )editar

@GDAE, se a resposta te serviu, pontue-a com um clique na lado esquerdo. Caso ela tenha resolvido seu problema marque-a como correta.

imagem do gravatar de BetoBeto ( 2017-08-25 16:05:17 +0100 )editar

Quando tento votar aparece: >5 pontos necessários para voto a favor

imagem do gravatar de GDAEGDAE ( 2017-08-25 21:44:57 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2017-08-24 17:38:08 +0100

Lidas: 34 vezes

Última atualização: Aug 26