Pergunte aqui
1

PROC não funciona no Calc

perguntadas 2017-10-19 14:43:25 +0200

imagem do gravatar de wolnerberg

updated 2017-10-19 14:45:24 +0200

Olá pessoal, tudo bem?

Estou migrando totalmente para o Linux, e inclusive, estou passando minhas planilhas para formato ODS.

Existe uma fórmula em minha planilha de Excel que não está funcionando no Calc. Pesquisei na internet, mas todas as orientações são para Excel, e as resoluções não funcionam no Calc. O estranho é que, ao abrir a planilha .xlsx no Calc, a fórmula funciona. Depois que passo para o formato .ods, não funciona mais.

A fórmula é a seguinte:

=SOMA((PROC(2;1/(NÚM.CARACT($'P2P LENDING'.D13:D35)>0);$'P2P LENDING'.D13:D35))+(PROC(2;1/(NÚM.CARACT($'P2P LENDING'.J14:J37)>0);$'P2P LENDING'.J14:J37))+(PROC(2;1/(NÚM.CARACT($'P2P LENDING'.P13:P36)>0);$'P2P LENDING'.P13:P36))+(PROC(2;1/(NÚM.CARACT($'P2P LENDING'.V13:V36)>0);$'P2P LENDING'.V13:V36)))

Essa fórmula faz a seguinte função: tenho 4 conjuntos de dados, que são recebimentos de valores mensais. Preciso que essa fórmula me retorne a soma dos valores pagos no mês corrente (últimos valores).

No Calc, a mensagem de erro mostrada é DIV/0.

Como proceder?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Ola @wolnerberg, tente o seguinte, primeiro converta, no Excel, de .xlsx para .xls, abra no Calc veja se esta funcionando e salve em .ods.

.

Mas se esta dando erro DIV/0, indica que a Operação de divisão esta com o denominador 0

.

Faça testes parciais da formula, por exemplo: NÚM.CARACT($'P2P LENDING'.D13:D35), e descubra onde esta o erro.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2017-10-19 16:37:50 +0200 )editar

Bom dia, @wolnerberg, caso não tenha resolvido ainda poste um link com uma planilha de exemplo para que possamos entender melhor.

imagem do gravatar de Júnio VieiraJúnio Vieira ( 2017-10-20 12:31:59 +0200 )editar

2 Respostas

1

respondidas 2017-10-25 11:38:50 +0200

imagem do gravatar de wolnerberg

Consegui resolver o problema, utilizando a seguinte função:

=SOMA((ÍNDICE($'P2P LENDING'.D13:D35;CORRESP(999999;$'P2P LENDING'.D13:D35))+(ÍNDICE($'P2P LENDING'.J14:J37;CORRESP(999999;$'P2P LENDING'.J14:J37))+(ÍNDICE($'P2P LENDING'.P13:P36;CORRESP(999999;$'P2P LENDING'.P13:P36))+(ÍNDICE($'P2P LENDING'.V13:V36;CORRESP(999999;$'P2P LENDING'.V13:V36)))))))

Troquei a fórmula do PROC por ÍNDICE + CORRESP.

O interessante é que, no formato xls e xlsx, o Libreoffic aceita a fórmula. Ao passar para o formato odt, não aceita mais.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2017-10-23 12:24:08 +0200

imagem do gravatar de Olivier

Utilize o Assistente de funções para analisar sua fórmula. Posicione o cursor na célula com erro e abra o menu Inserir - Função e clique na aba Estrutura.

A figura abaixo mostra sua função numa planilha vazia (os erros são normais neste caso)

Descrição da imagem

Uma das subfórmulas deve estar com erro.

Em geral, é um problema de incompatibilidade de tipos, ou seja, algum número se passando por cadeia de caracteres ou vice versa.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2017-10-19 14:43:25 +0200

Lidas: 356 vezes

Última atualização: Oct 25 '17