Pergunte aqui
1

Problemas com intervalos nomeados no Calc.

perguntadas 2018-05-21 21:42:31 +0200

imagem do gravatar de cjcesconetti

updated 2019-10-31 18:30:03 +0200

imagem do gravatar de Schiavinatto

Prezados(as).

Trabalho no Calc nomeando intervalos (listas e/ou tabelas inteiras) para facilitar e dinamizar o acesso aos dados para cálculos posteriores. Assim, posso usar a sintaxe tbNomeTabela!'RótuloColuna' em uma equação. Contudo, isso tem funcionado apenas para intervalos nomeados dentro de uma mesma planilha, mesmo este intervalo estando como escopo Documento (Global)..

Exemplo:

Em Planilha1 tenho o intervalo nomeado tbPH correspondendo a $Planilha1.$A$4:$F$28 (imagem em anexo), como escopo Documento (Global).

Descrição da imagem

Em $Planilha1.$H$1 faço o cálculo =MÉDIA(tbPH!'phmax'). Tenho um resultado (=6,5)! OK!

Em $Planilha2.$H$1 uso a mesma equação consultando o intervalo da Planilha1, ou seja, =MÉDIA(tbPH!'phmax'). Tenho um erro do tipo "#Ref!". ERRO!

OPÇÕES configuradas:

Opções de fórmulas: Calc A1. Sintaxe para referências quando expressas na forma texto: Calc A1.

Quais as possíveis causas disso acontecer?

INFO: Sistema KDE Neon 5.12.5. LibreOffice 6.0.4.2. Também já testei em outras versões da Suite e nas distros Kubuntu, Ubuntu, Mint 18.3, sem sucesso.

Desde já, obrigado.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Como usuário Linux há 9 meses, estou migrando todas as minhas planilhas do Excel 2016 para o Calc, só que estou tendo alguns problemas, o principal dele, foi esse.

Com a mente aberta para a nova suite office, estou conseguindo fazer praticamente tudo que eu fazia no MS Office.

O LibreOffice é fantástico e já me apeguei, assim como o Linux.

imagem do gravatar de cjcesconetticjcesconetti ( 2018-05-21 21:49:56 +0200 )editar
1

Ola @cjcesconetti seja bem vindo ao Grupo, realmente, não funciona em uma planilha diferente, mesno estando Escopo: Documento Globaleu divulguei aqui no ask https://ask.libreoffice.org/pt-br/que..., mas não havia testado em planilhas diferente.

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-05-22 02:56:22 +0200 )editar

Você sabe que pode nomear formulas também, aquela fórmula enorme que vai reperir diversas vezes, pode-se nomear. Na Caixa de Texto / Gerenciar nomes... / Adicionar / Digite o nome / digite ou cole a fórmula / Adicionar. Para usar digite =nomedado

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-05-22 03:03:38 +0200 )editar

Olá @Gilberto Schiavinatto. Muito obrigado. Como eu comentei, sou novo usuário do LibreOffice e estou entusiasmado com suas possibilidade. Também aplaudo as pessoas que ajudam e compartilham conhecimento aqui no fórum. Entendi. Seria fantástico se fosse possível, não é...? Obrigado pela dica.

imagem do gravatar de cjcesconetticjcesconetti ( 2018-05-22 03:33:39 +0200 )editar

1 Resposta

0

respondidas 2019-10-31 17:42:11 +0200

imagem do gravatar de cjcesconetti

Há basicamente duas soluções possíveis para chamar intervalos de tabelas criadas.

Exemplo:

Descrição da imagem

1a forma) Definindo nome: Caminho: Inserir > Definir nome.

Para a seleção A1:C6 (imagem), foi dado o nome "tbDados":

Na função de soma, para chamar a coluna de 'tbDados', basta usar:

=SOMA(tbDados!'Coluna_A')

DESVANTAGEM: NÃO posso utilizar esta forma em células de qualquer planilha do arquivo, somente naquela onde a seleção está. || VANTAGEM: ao fechar o arquivo do Calc e abrí-lo novamente, a escrita desta fómula se mantem.

2a forma) Definindo intervalo: Caminho: Dados > Definir intervalo.

Para a seleção A1:C6 (imagem), foi dado o nome "dbDados":

Na função de soma, para chamar a coluna de 'dbDados', basta usar:

=SOMA(dbDados[Coluna_A])

VANTAGEM: posso utilizar esta forma em células de qualquer planilha do arquivo. || DESVANTAGEM: ao fechar o arquivo do Calc e abrí-lo novamente, esta mesma fómula estará escrita na sua forma literal:

=SOMA($Planilha1.$B$2:$B$6)

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-05-21 21:42:31 +0200

Lidas: 428 vezes

Última atualização: Oct 31 '19