Pergunte aqui
1

Fórmulas do Calc 6.1.3.2 não funcionam no Calc 3.1 e nem no Excel

perguntadas 2018-11-09 15:34:52 +0100

imagem do gravatar de Zaggor

Bom dia,

Poderiam confirmar a minha afirmação? Fiz a seguinte fórmula no Calc 6.1.3.2: =SOMASES('31'.$D$2:$D$40;'31'.$H$2:$H$40;"ok") Quando eu abro no Calc 3.1, além dele renomear o SOMASES para SUMIFS, mesmo após colocar o nome da função corretamente na fórmula, ele continua não fazendo o cálculo, fica como se não houvesse nenhuma fórmula, sendo que ela está ali descrita.

Podem me ajudar? É urgente...

Obrigado

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Veja em Ferramentas /Opções / LibreOffice Calc / Fórmula em Opções de fórmula, veja se esta marcado [ v ] Utilizar nomes ingleses das funções.

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-11-09 16:24:40 +0100 )editar

Lembrando no LibO 3.1 acho que ainda não esta disponível a função SOMASES,

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-11-09 17:32:16 +0100 )editar

e qual seria a fórmula que substitui?

imagem do gravatar de ZaggorZaggor ( 2018-11-09 17:34:37 +0100 )editar

desculpa...a função? ja que a SOMASES não tem disponível?

imagem do gravatar de ZaggorZaggor ( 2018-11-09 17:35:14 +0100 )editar

Vide solução de SOMASES sem a função no complemento da minha resposta.

Mas acho que deveria atualizar o LibO.

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-11-09 17:54:29 +0100 )editar

1 Resposta

0

respondidas 2018-11-09 16:20:49 +0100

updated 2018-11-09 17:55:22 +0100

Ola @Zaggor, seja bem vindo ao Grupo.

Na sua fórmula deve ter algo errado: =SOMASES('31'.$D$2:$D$40;'31'.$H$2:$H$40;"ok")

Função tem estes parâmetros: =SOMASES(IntervaloSoma; Intervalo1; Critério1 ;Intervalo2; Critério2)


COMPLEMENTO:

SOLUÇÃO SEM A FUNÇÃO SOMASES

Ex. dada a tabela: (Inicia na linha1)

colunaA  colunaB  ColunaC
valor  vencimento  situação
100 10/01/2013 ANTECIPADO
50  10/01/2013 A PAGAR
30 08/01/2013  A PAGAR

Ex. Necessito saber por vencimento o valor A PAGAR (inicia na linha 7)

08/01/2013  09/01/2013  10/01/2013
((fórmula1))  ((fórmula2))  ((fórmula3))

fórmula1 =SOMARPRODUTO(N($B$2:$B$4=A7);N($C$2:$C$4="A PAGAR");$A$2:$A$4)

fórmula2 =SOMARPRODUTO(N($B$2:$B$4=B7);N($C$2:$C$4="A PAGAR");$A$2:$A$4)

fórmula3 =SOMARPRODUTO(N($B$2:$B$4=C7);N($C$2:$C$4="A PAGAR");$A$2:$A$4)


editar assinalar como ofensivo Excluir Link mais

Comentários

@Zaggor, comentou: "A fórmula está correta, pois funciona no calc 6 e no excel tb, não está funcionando no calc 3.1. Apenas preciso saber se uma versão é compatível com a outra, e se não for, se pode dar erro em alguma fórmula(não reconhecer a fórmula) e se existe algo que eu possa fazer!

Obrigado"

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-11-09 17:27:01 +0100 )editar

Na sua fórmula: =SOMASES('31'.$D$2:$D$40;'31'.$H$2:$H$40;"ok")

O primeiro '31' é nome de uma área ?

Lembrando no LibO 3.1 acho que ainda não estava disponível a função SOMASES, de uma olhada na lista de funções, digite = e clique no botão [fx]

Não use Adicionar Resposta use Comentar

imagem do gravatar de SchiavinattoSchiavinatto ( 2018-11-09 17:34:48 +0100 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2018-11-09 15:34:52 +0100

Lidas: 64 vezes

Última atualização: Nov 09 '18