Pergunte aqui
1

Desempenho do CALC

perguntadas 2019-01-15 16:38:11 +0200

imagem do gravatar de Cristovão

Tenho planilhas bastante pesadas e a titulo de melhorar o desempenho do calc, pesquisei na internet onde aconselham a fazer algumas alterações na opção "Memória", porém tanto nesta versão que atualmente estou usando a 6.1.4.2, bem como em anteriores, não existe essa opção "Memória" no desdobramento da opção "Ferramentas". Como faço para ir até essa opção "Memória"?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Ola @Cristovão, estas planilhas contem imagens ?

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-01-15 19:57:46 +0200 )editar

Sem imagens!

imagem do gravatar de CristovãoCristovão ( 2019-01-17 11:06:20 +0200 )editar

2 Respostas

0

respondidas 2019-01-17 20:15:42 +0200

imagem do gravatar de Olivier

A opção Memória não existe mais por que era do tempo em que os computadores tinham pouca memória. Esqueça essa dica.

Aqui vão outras, muito melhor e que servem para qualquer programa de planilha:

Dica 1: Tendo uma coluna B que é uma função da coluna A, e sabendo que você tem 100.000 células na coluna A, o que você faz? Você faz 100.000 formulas em B? Copia a fórmula de B1 até B100000?

Se fizer, ai está o erro. O computador vai interpretar 100.000 vezes a mesma fórmula.

Mas se você usar uma fórmula de matriz, ele vai interpretar 1 fórmula e calcular 100.000 vezes . Seu arquivo tem 99.999 fórmulas a menos.

https://help.libreoffice.org/6.1/pt-B...

Dica 2: Muito comum. Sua planilha é um dump de uma tabela do banco de dados ou uma consulta com milhares de linhas. Você tem de consolidar os dados em C, selecionando condições:

=SE( A1="OK";B1;0)
=SE( A2="OK";B2;0)

E depois você soma todas as células em C....

Mais uma vez, formulas em excesso.

Tente

=SOMASE(...)
=SOMASES(...)
=SOMARPRODUTO(...)

etc...

São fórmulas que consolidam dados.

E por ai vai.

E insisto: serve pra qualquer programa de planilha.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2019-01-16 13:54:51 +0200

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Bom dia!

Estava trabalhando com uma planilha bem pesada e o Calc estava lento. Fiz o seguinte:

Ferramentas - Opções - LibreOffice - Avançado: em Opções do Java, desmarquei "Utilizar um JRE (Java Runtime Environment).

editar assinalar como ofensivo Excluir Link mais

Comentários

Fiz esse procedimento, porém a melhora foi mínima. O desempenho continua péssimo!

imagem do gravatar de CristovãoCristovão ( 2019-01-17 18:21:30 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-01-15 16:38:11 +0200

Lidas: 60 vezes

Última atualização: Jan 17