Pergunte aqui
0

CONT.SE não funciona com valores calculados

perguntadas 2019-10-08 23:59:19 +0200

imagem do gravatar de Fátima

Tenho 2 colunas com células calculadas com fórmulas para retornar partes de textos.

Coluna AB =ESQUERDA(E1;PROCURAR(" e ";E1))

Coluna AC =DIREITA(E1;NÚM.CARACT(E1)-PROCURAR(" e ";E1)-2)

As demais colunas AD e AE, AF e AG, etc. intercalam estas duas fórmulas e tudo funciona perfeitamente.

Numa outra célula uso a fórmula =CONT.SE(AB1:AL1;W1) para retornar o número de repetições de W1 no intervalo AB1:AL1. O problema é que o CONT.SE só funciona se o valor do critério W1 estiver nas colunas calculadas com a mesma fórmula DIREITA ou ESQUERDA. Se o valor da W1 estiver numa célula calculada da =ESQUERDA e o outro na célula da =DIREITA, ele retorna apenas 1 delas, não considerando como uma repetição. Porque isso acontece. Até tentei usar a conversão para =TEXTO() mas continua não considerando os textos como iguais.

Por favor, me deem uma dica do que está errado. Obrigada, Fátima

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Olá, fatima! Se for possível anexar um arquivo da nuvem (Google Drive, Dropbox, etc.) através do link, excluindo informações confidenciais para que possamos entender melhor o problema.

imagem do gravatar de Leandro VieiraLeandro Vieira ( 2019-10-09 00:19:44 +0200 )editar

1 Resposta

1

respondidas 2019-10-09 06:08:12 +0200

updated 2019-10-09 06:11:43 +0200

Ola @Fátima, compare o valor das duas colunas, exemplo: =Wi=V1, se visualmente for igual é a resposta for FALSA, verifique se não há espaço antes ou depois da palavra.

Veja exemplo na imagem: A segunda linha a formula é =ESQUERDA(F9;8), a resposta é "Bvcdcdcd", e na terceira linha a formula é =ESQUERDA(F9;9), a resposta é "Bvcdcdcd ", tem um espaço a mais que não é visível.

Descrição da imagem

-----------------------------------------------------------------------------

ATENÇÂO:: Para dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais

Comentários

@Fátima, comentou:

É isso! As células não são iguais porque tinham espaço em branco que eu não via. Resolvi utilizando o ARRUMAR(). Agradeço imensamente. Parabéns pelo site

-----------------------------------------------------------------------------

ATENÇÂO:: Para dar mais detalhes a sua pergunta, use Descrição da imagem na pergunta ou Descrição da imagem abaixo. Grato.

Caso a resposta atendeu sua necessidade, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

imagem do gravatar de Gilberto SchiavinattoGilberto Schiavinatto ( 2019-10-09 19:55:45 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2019-10-08 23:59:19 +0200

Lidas: 18 vezes

Última atualização: Oct 09