Pergunte aqui
0

Busca por partes do conteúdo no Calc

perguntadas 2012-12-26 19:22:26 +0200

imagem do gravatar de daniel.capua

Olá galera,

Preciso saber como fazer o seguinte: Quero contar os itens de uma lista que é composta por 20 itens A B C D etc. Mas na lista estes podem se combinar na mesma célula, assim: célula A1 - B célula A2 - A, D, F Célula A3 - B, F (...)

Tentei usar COUNTIF ($A1$A20;"d"), por exemplo, mas a função só conta as células que só contem "D" neste caso. Há como buscar termos assim no calc.

Daniel

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

1 Resposta

1

respondidas 2012-12-26 23:45:07 +0200

imagem do gravatar de Grafeno

Olá Daniel,

Se o "D" não aparecer mais de uma vez dentro de uma mesma célula, a solução pode ser:

=CONT.SE($A1:$A20;".*D.*")

Onde o ".*" serve para indicar que antes ou depois do "D" pode existir uma expressão com zero ou mais caracteres de comprimento. Então, o "D" será contado se estiver no início, no fim, sozinho ou em qualquer posição intermediária dentro das células.

Obs.: Meu LibO Calc 3.6.4.3 (Ubuntu) está em PT-br, por isso, testei o CONT.SE ao invés do COUNTIF.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2012-12-26 19:22:26 +0200

Lidas: 252 vezes

Última atualização: Dec 26 '12