Pergunte aqui
0

CALC LENTO

perguntadas 2013-03-12 23:02:07 +0100

imagem do gravatar de andre.forno

Tenho instalado a suite versão 4.0.0.3 no sistema operacional Windows 7 64 bits professional. Após algum tempo com a planilha (CALC) em aberta o mesmo fica lento. Verifiquei consumo de memória e CPU e o mesmo esta estável, ou seja, sem aumento algum, somente a suite é que fica lenta.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Mesmo problema. Uso CALC 4.0.3.3, planilha c/ 104.000 células, mais de 6000 revisões, quase 2000 horas de edição, tamanho 1MB, macros, e já atravessou 4 versões do CALC desde criada. Ano passado começou a lentidão qdo faço uma entrada em células (lista pré-definida) demora e ainda exibe "não respondendo" na barra de status, até que faz a entrada. Única solução está sendo pegar uma versão antes dos problemas e colar os dados novos (atuais), até que gradativamente a lentidão volta.

imagem do gravatar de yurytkyurytk ( 2013-10-08 19:52:46 +0100 )editar

Ele também demora muito a friltrar dados. Na versão 4.1.1 ela nem abre. Estou baixando a 4.1.2 para ver se funciona. Ela tem também milhares de células com formatação condicional, fórmulas, etc. Poderia ser previsto que uma planilha com tantos recursos fosse lenta, mas porque quando eu uso o backup antigo e colo os dados novos ela vai gradativamente ficando lenta, ao invés de ser lenta desde o início? Despois que está lenta, diminuir o volume de dados não adianta, só mesmo voltar ao backup é de deixa ela rápida novamente.

imagem do gravatar de yurytkyurytk ( 2013-10-08 19:59:36 +0100 )editar

Acrescentando... trabalho numa Empresa Pública, onde todos os serviços dependem de uma planilha específica cujo número de células varia entre 6000 a 10000 com 200 a 600 KB de tamanho de arquivo no máximo, em formato ".ODS". ...

imagem do gravatar de taltal ( 2013-12-01 13:15:41 +0100 )editar

Isso acontece tanto no BROffice 2.1 (máquinas com Windows XP 1GB RAM), LibreOffice 3.3 e LibreOffice 4.1.3.2 (máquinas com Windows 7 64bits 4GB RAM). Já utilizamos antivirus, já formatamos as máquinas, tentamos todas as configurações possíveis, inclusive aconselhadas por membros deste fórum. ...

imagem do gravatar de taltal ( 2013-12-01 13:16:01 +0100 )editar

Pensamos que poderia ser a rede (Intranet) mas, até mesmo em máquinas recém-formatadas e desconectadas da rede, demora cerca de 15 minutos para abrir a planilha, a cada 3 caracteres digitados, a planilha trava durante 10 minutos e para salvar, demora de 30 minutos a 2 horas. ...

imagem do gravatar de taltal ( 2013-12-01 13:16:16 +0100 )editar

Já substituímos os arquivos ".ODS" por novos arquivos, já testamos também com outros formatos como o ".XLS", etc... o interessante disso tudo é que ao copiar os dados da planilha para outra como por exemplo: Gnumeric, Kingsoft Free, MS Office, não ocorre lentidão ou travamento algum. ...

imagem do gravatar de taltal ( 2013-12-01 13:16:36 +0100 )editar

Verificamos também que, o arquivo "SOFFICE.BIN" consome Megabytes ao extremo de cada máquina, sem contar o uso de porcentagem do processador (que varia de acordo com o número de "Cores", mas garanto que é 100% de um determinado núcleo), sem contar que ao testar no meu PC de casa, descobri que além de tudo, o Libreoffice somente trabalha com 1 núcleo de processador, portanto, mesmo num Core i7/AMD FX de 8 núcleos (também testado), foi a mesma coisa. ...

imagem do gravatar de taltal ( 2013-12-01 13:17:14 +0100 )editar

Para mim, está mais do que claro que o problema está no LibreOffice, portanto, algo está errado, muito errado no desenvolvimento do mesmo... por causa disso, como só podemos instalar software que possuem licença gratuita para uso corporativo, iremos verificar a possibilidade de uso do “Gnome Gnumeric”, junto a empresa, para podermos ter rendimento durante o serviço.

imagem do gravatar de taltal ( 2013-12-01 13:21:23 +0100 )editar

5 Respostas

1

respondidas 2016-04-27 04:45:36 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

LibreOffice slow? Here’s how to speed it up

Fortunately it only takes a few seconds and is really simple to improve the LibreOffice speed considerably. Here are the instructions: (I used 5 version)

  1. Open up LibreOffice Writer.
  2. Click Tools -> Options.
  3. Click Memory (under LibreOffice).
  4. Increase the Graphics Cache -> Use for LibreOffice value (try 128 MB to start and increase further if needed).
  5. Increase Memory per object (try 20MB to start).
  6. Click Advanced
  7. Untick the “Use a Java runtime environment”-option.
  8. Click OK.

One quite easy way to speed up LibreOffice (and OpenOffice) is disabling Java.

This can make a huge difference in the speed of LibreOffice applications, but more special features might require Java to be enabled (in which case you’ll get a popup asking if you wish to enable it again).

That’s it. Your LibreOffice software should now load far more quickly and perform faster.

LeoBastos (leonardo@infobastos.com)

---==-----------------===--------------

LibreOffice está lenta? Veja como acelerá-lo

Felizmente leva apenas alguns segundos e é realmente simples para melhorar a velocidade LibreOffice consideravelmente. Aqui estão as instruções : (eu usei a versão 5)

  1. Abra o BrOffice Writer .
  2. Clique em Ferramentas - > Opções.
  3. Clique em Memória ( sob LibreOffice ) .
  4. Aumentar o cache Graphics - > Use para o valor LibreOffice (tente 128 MB para iniciar e aumentar ainda mais se necessário).
  5. Aumento de memória por objeto (tente 20MB para começar ) .
  6. Clique em Avançadas
  7. Desmarque a opção "Usar um ambiente de execução Java" -opção .
  8. Clique em OK.

Uma maneira muito fácil de acelerar o LibreOffice (e OpenOffice ) é incapacitante Java.

Isso pode fazer uma enorme diferença na velocidade de aplicações do LibreOffice , mas as características mais especiais pode requerer Java para ser habilitado (caso em que você vai ter um pop-up perguntando se você deseja ativá-lo novamente ) .

É isso aí. Seu software LibreOffice agora deve carregar muito mais rapidamente e executar mais rápido.

LeoBastos ( Leonardo@infobastos.com )

editar assinalar como ofensivo Excluir Link mais
1

respondidas 2013-12-01 16:04:43 +0100

imagem do gravatar de tal

updated 2013-12-01 16:15:59 +0100

Consegui uma pequena solução aqui: Instalei o "Calligra Suite v2.6.2.2" para Windows e abri o arquivo ".ODS" através dele. Simplesmente gravei outro arquivo ".ODS" (com outro nome é claro!) e qual foi a minha surpresa ao constatar que o arquivo, que tinha 592KB, ficou com 192KB. Abri o arquivo no "LibreOffice 4.1.3.2" e após corrigir as formatações de algumas colunas e linhas, salvei pelo LibreOffice e "voi-lá"... 206KB (8285 linhas x 5 colunas), arquivo "SOFFICE.BIN" consumindo entre 0% e 5% até agora, com consumo de memória no momento de aproximadamente 88000KB. Então comecei a achar que o problema está no módulo do LibreOffice, responsável pelo salvamento dos arquivos ".ODS" . Por que ao salvar qualquer arquivo ".ODS" por um software similar como o Calligra Suite, funciona rápido e sem travamentos no LibreOffice e quando salvo pelo próprio, os arquivos ficam maiores, lentos e travam quando são editados? Esta é a questão.

editar assinalar como ofensivo Excluir Link mais

Comentários

Para se ter uma idéia, bastou eu testar alguns acréscimos de dados (1000 linhas de uma planilha mais antiga) e a planilha já passou de 206KB para 350KB... abri de novo pelo Calligra e salvei o arquivo com o mesmo nome, em outra pasta... 226KB! Antes eu achava, agora eu tenho certeza. Então, como considero o LibreOffice Calc a planilha mais completa, peço aos desenvolvedores do mesmo que, verifiquem o que está ocorrendo, pois, está prejudicando várias pessoas que reclamaram disso pela Internet.

imagem do gravatar de taltal ( 2013-12-01 17:35:24 +0100 )editar
0

respondidas 2016-02-01 18:20:19 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Olá. Tenho enfrentado o mesmo problema relatado e após vários testes passo a descrevê-lo.

Uso excessivo de memória pelo Calc.

Abaixo descreverei os testes realizados e os resultados obtidos.

Arquivo Xlsx, com 123.000 linhas e 17.211KB não abre no Calc testado nas versões 4.4.7 e 5.0.4, consome quase toda memória ram disponível do sistema. No MS-Excel o arquivo abre em aproxiamdamente 30 segundos e consome 73,2MB de Ram.

Convertendo no Excel o arquivo em Xls, com 65.536(limite máximo, exclui linhas) e fica com 34.0001KB, abre no Calc porém demora quase 6 minutos e consome quase toda memória ram disponível do sistema. No MS-Excel o arquivo abre em aproxiamdamente 30 segundos e consome 73,2MB de Ram. Ao tentar fechar o arquivo ou o Calc, ele trava e só encerrando o Calc via processo.

Tenho imagens dos consumos de memória do Calc e Excel com os arquivos abertos.

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-08-11 13:42:00 +0100

imagem do gravatar de Josir

Tente colocar mais detalhes sobre o problema!

  • Acontece como qualquer planilha ou somente com uma específica ?
  • Você se certificou se instalou a versão 64bits do LibreOffice ?
editar assinalar como ofensivo Excluir Link mais

Comentários

Se me permite, só uma correção na dúvida: a versão do LibreOffice é uma só para 32 ou 64 bits, no caso do Windows. No meu caso (máquinas Windows XP 32 bits e Windows 7 64 bits), que especifiquei nos comentários da pergunta do colega, notei que só ocorre com planilha acima de 3000 células, apesar que, com qualquer planilha passando das 1000 células nota-se o início da lentidão do software.

imagem do gravatar de taltal ( 2013-12-01 13:30:07 +0100 )editar
0

respondidas 2013-12-01 15:28:44 +0100

imagem do gravatar de Olivier

Pelos comentários colocados na pergunta resume-se em

  1. A planilha tem 100.000 células
  2. Esta com milhares de fórmulas
  3. esta com formatação condicional em milhares de células
  4. esta com o controle de alterações ativado (6000 revisões)
  5. Sofre edição com listas predefinidas em milhares de células

Não vejo como nao ficar lento...

A repetição desmedida de fórmulas, condições de entrada, gravação de alterações não tem como ajudar.

É necessário rever a forma como se faz a edição desta planilha:

  • Usar fórmulas consolidadoras (ex. SOMASE, CONT.SE)
  • Desativar o cálculo automático enquanto edita as células
  • Usar formulas de matriz {FUNC}
  • Desativar o registro de alterações
  • usar estilos para decoração de células
  • se a edição dos dados envolve milhares de linhas, lembre-se que ele deve guardar na memória os passos a retroceder, portanto o consumo de memória sempre aumenta, até o limite do numero de passos especificados para desfazer a edição. Você pode querer diminuir o valor de 100, que é o padrão.

Lembrando que são só sugestão de quem não viu a planilha.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2013-03-12 23:02:07 +0100

Lidas: 3,308 vezes

Última atualização: Apr 27 '16