Pergunte aqui
0

Função SE Calc

perguntadas 2013-06-28 21:56:56 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Boa tarde.

Estou tentando usar a função SE do Calc, mas estou com dificuldade de colocá-la no seguinte argumento:

Quando A2 for COMBUSTÍVEL ou ABASTECIMENTO, então copia valor de A3. Senão, nulo.

A dúvida está em incluir no argumento a ocorrência de uma condição OU outra. Como faço?

Já vou agradecendo as respostas ;)

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

6 Respostas

0

respondidas 2013-07-04 05:42:06 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Mais uma coisa: notei que se eu usar a função com a seguinte sintaxe: =SE(OU(A2="ABASTECIMENTO";A2="COMBUSTIVEL");A3;"") , ela apenas irá funcionar se a célula contiver exatamente um valor ou outro, nesse caso, ABASTECIMENTO ou COMBUSTÍVEL. Se a célula contiver uma informação diferente, por exemplo, ABASTECIMENTO NO POSTO G10, o calc entenderá como valor senão.

Como eu faço nesse caso, para ele reconhecer apenas uma palavra no meio de uma frase dentro da célula?

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-07-04 17:21:42 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Olá!

Tente o seguinte:

=SE(PESQUISAR("Abastecimento";A2;1)=1;A3;"")

OBS1: Lembrando que para dar certo a palavra "combustível" ou "abastecimento" tem que estar no início da frase.

OBS2: Não difere maiúsculas de minúsculas.

PS: Avisa se deu certo!

Abraços!

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-07-05 05:37:35 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Olá, novamente.

Havia esquecido que você tem duas condições. A fórmula vai ficar maior do que eu esperava. Eu ía sugerir o seguinte: =SE(PESQUISAR("Abastecimento";A2;1)=1;A3;SE(PESQUISAR("Combustível";A2;1)=1;A3;""))

Ocorre que, caso você coloque "combustível" na A2 ele não vai terminar o teste lógico, pois irá apresentar um erro (#VALOR!). Apesar do "erro" ser diferente de 1, ele não termina o raciocínio... empaca ali mesmo.

Então vamos ter que "driblar" esse problema!

E aqui vai a solução:

=SE(SEERRO(PESQUISAR("Abastecimento";A2;1)=1;0);A3;SE(SEERRO(PESQUISAR("Combustível";A2;1)=1;0);A3;""))

Agora eu espero que dê certo!!!

Att.

Mayane

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-07-08 18:32:01 +0100

esta mensagem está marcada como wiki comunitário

Esta mensagem é um wiki. Qualquer pessoa com karma >75 é bem-vinda para a melhorar.

Oi Mayane

Agora deu certo. Mas não abusando de sua paciência, vc pode me explicar a sintaxe dessa função que vc me passou? Gostaria de entender ela para saber como funciona, pois assim fica fácil quando eu precisar fazer alguma modificação para obter outros resultados.

Att

editar assinalar como ofensivo Excluir Link mais

Comentários

Ok! Vou tentar explicar...

imagem do gravatar de MayanekbMayanekb ( 2013-07-09 17:33:14 +0100 )editar

A função "Pesquisar" busca uma sentença ou palavra específica. Assim ela irá procurar a palavra que você quer, no caso "abastecimento" na célula "A2", sendo que ela será verificada a partir da primeira letra "1". Caso ela encontre retornará 1, caso não encontre ela retorna um erro. Então, "SE" o resultado da busca ("Pesquisar") for 1 eu uso o valor de A3 se não faço a pesquisa por "combustível".

imagem do gravatar de MayanekbMayanekb ( 2013-07-09 17:35:41 +0100 )editar

Ocorre que temos que considerar a possibilidade do erro. Então, se ao PESQUISAR("Abastecimento";A2;1) retornar um erro ("SEERRO") então é para ser usado o "0". Essa é a lógica. Poderia usar invertido a posição do "=1", ficaria até mais compreensível, assim: =SE(SEERRO(PESQUISAR("Abastecimento";A2;1);0)=1;A3;SE(SEERRO(PESQUISAR("Combustível";A2;1);0)=1;A3;"")) O resultado seria o mesmo, pois a lógica é a mesma. Espero que tenha conseguido entender, qualquer coisa é só avisar. Att. Mayane

imagem do gravatar de MayanekbMayanekb ( 2013-07-09 17:41:16 +0100 )editar

Valeu.. entendi ;)

imagem do gravatar de netbragasnetbragas ( 2013-07-11 00:07:26 +0100 )editar
0

respondidas 2013-06-29 19:34:28 +0100

imagem do gravatar de Olivier

Outra alternativa:

=SE(OU(A2="ABASTECIMENTO";A2="COMBUSTIVEL");A3;"")
editar assinalar como ofensivo Excluir Link mais

Comentários

Obrigado pelas resopstas...

;)

imagem do gravatar de netbragasnetbragas ( 2013-07-01 18:23:18 +0100 )editar
0

respondidas 2013-06-29 07:41:57 +0100

imagem do gravatar de Grafeno

updated 2013-06-29 07:45:23 +0100

Olá,

No caso, uma solução é aninhar 2 funções SE:

=SE(A2="COMBUSTÍVEL";A3;SE(A2="ABASTECIMENTO";A3;""))

Assim vc testa se é COMBUSTÍVEL primeiro. Se não for, ocorrerá um segundo teste para ver se é ABASTECIMENTO. Daí se não for nenhuma das duas coisas, a função retornará vazio "".

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2013-06-28 21:56:56 +0100

Lidas: 19,468 vezes

Última atualização: Jul 08 '13