Pergunte aqui
0

Contando uma sequência de palavras dentro de uma mesma célula

perguntadas 2013-11-29 14:53:53 +0200

imagem do gravatar de Beto

updated 2019-03-01 18:39:25 +0200

Como contar nomes dentro de uma mesma célula, que função usar? Já que a CONT.SE Só serve para o conteúdo total de uma célula?

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

0

respondidas 2013-11-29 14:56:16 +0200

imagem do gravatar de Beto

updated 2013-11-29 14:57:00 +0200

A maneira elegante de contar palavras no Calc é usar a função =CONT.SE(), mas ela só funciona com o conteúdo total que estiver na célula. Se estiverem vários nomes separados em linha a função retornará zero. Então, aqui vem a gambiarra, na coluna ao lado, em cada linha deveremos colocar a fórmula =SE() seguida da fórmula =PESQUISAR() as quais deverão ser combinadas mais ou menos assim: =SE(PESQUISAR($D$1;A1);1). Os cifrões em torno da nomeação da célula D1 são para que ao arrastar a fórmula somente sejam mudados os endereços da célula A, visto que a palavra a ser pesquisada será digitas na célula D1.

Após isto, é só colocar a fórmula =CONT.SE(B1:B17;"VERDADEIRO") no lugar que se quer que saia o resultado. Vejam este post que fiz em meu blog como exemplo:

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2013-11-29 15:32:19 +0200

imagem do gravatar de Olivier

Para contar/detectar ocorrências dentro do conteúdo de uma célula é necessário ativar a busca dentro das células:

Vá em Ferramentas -> Opções -> LibreOffice Calc -> Calcular e desmarque a caixa "Critérios de pesquisa = e <>..."

Depois faça uma busca ou use as funções que dependem de critérios de pesquisa.

Outro poderoso recurso de seleção de strings dentro de células são as expressões regulares. veja a Ajuda detalhes sobre este recurso.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2013-11-29 14:53:53 +0200

Lidas: 4,878 vezes

Última atualização: Nov 29 '13