Pergunte aqui
2

Evitando dados duplicados em uma planilha

perguntadas 2014-02-19 18:43:46 +0200

imagem do gravatar de vitalrn

updated 2016-04-17 16:34:56 +0200

imagem do gravatar de Grafeno

Gostaria de saber como configurar uma coluna no calc para não aceitar dados repetidos, os dados são números e eu não posso repetir.

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Pode explicar um pouco mais, você vai inserir os dados manualmente? Na pergunta você coloca que a coluna do Calc deve aceitar dados repetidos, São esses mesmo dados que são os números?

imagem do gravatar de BetoBeto ( 2014-02-20 12:59:35 +0200 )editar

sim os dados serão inseridos manualmente a planilha vai ter uma coluna com os dados do cpf e outra com os dados do titulo e não gostaria de correr o risco de inserir dados repetidos.

imagem do gravatar de vitalrnvitalrn ( 2014-05-08 15:04:30 +0200 )editar

Desculpe realmente me expressei errado peço desculpas.

imagem do gravatar de vitalrnvitalrn ( 2014-05-08 15:07:52 +0200 )editar

2 Respostas

1

respondidas 2014-05-08 17:18:48 +0200

imagem do gravatar de Grafeno

updated 2014-05-08 17:24:35 +0200

Olá,

Uma solução interessante é usar a Formatação Condicional na coluna para ser alertado quando digitar um número repetido.


Exemplo

1- Selecione a coluna do CPF, no exemplo é a Coluna A, depois vá em Formatação > Formatação Condicional > Condição.
2- Escolha "A formula é" e insira: =CONT.SE(A$1:A$1048576;A1)>1

Descrição da imagem

3- Em “Aplicar estilo” escolha “Novo estilo...”.
4- Na aba “Organizador” digite “Repetido” no campo Nome.
5- Vá na aba “Efeitos da fonte” e escolha “Vermelho” para a “Cor da fonte”.
6- Para aumentar o realce, escolha um fundo paras células que tiverem os valores repetidos na aba “Plano de fundo”. Eu optei por um amarelo claro mais frio.

Pronto, agora é só testar para ver como fica.

Descrição da imagem


Atte,
Grafeno

editar assinalar como ofensivo Excluir Link mais

Comentários

muito claro e objetivo parabéns resolveu. valeu mesmo.

imagem do gravatar de vitalrnvitalrn ( 2014-05-09 18:25:04 +0200 )editar
1

respondidas 2014-02-20 15:40:18 +0200

imagem do gravatar de Beto

Dê uma olhada neste artigo, pode ser que vá no rumo... Meu blog

editar assinalar como ofensivo Excluir Link mais

Comentários

Boa noite. Ficou clara a explicação, realizei o processo com facilidade, mas como faço para várias colunas?

imagem do gravatar de ChicleteChiclete ( 2016-03-03 23:05:57 +0200 )editar

Abra uma nova pergunta e explique um pouco mais seu projeto, pois não entendi o que quer fazer,

imagem do gravatar de BetoBeto ( 2016-03-04 12:03:32 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2014-02-19 18:43:46 +0200

Lidas: 5,027 vezes

Última atualização: May 08 '14