Pergunte aqui
1

Como referenciar uma planilha a partir de uma célula?

perguntadas 2014-03-18 21:51:17 +0200

imagem do gravatar de Elder Marco

updated 2016-04-17 03:26:27 +0200

imagem do gravatar de Grafeno

Olá,

Estou com o seguinte problema. Tenho várias planilhas criadas em um documento do Calc. E uma outra planilha que tem o objetivo de resumir com resultados os dados presentes nessas planilhas em uma única tabela. Assim, por exemplo, para gostaria de calcular a média de todos os valores num dado intervalo de colunas da planilha XYZ e colocar esse valor em uma célula de outra planilha, no mesmo documento. Eu poderia fazer:

= MÉDIA(XYZ.E9:E18)

No entanto, se eu mudar o nome da planilha por algum motivo, terei que alterar a fórmula também e algumas são mais complicadas. O nome de cada planilha é colocada em uma célula dentro dessa planilha onde quero salvar os valor médio e gostaria de referenciar essa célula, por esse valor. Seria algo do tipo (que não funciona)

= MÉDIA(C10.E9:E18)

Onde o nome da planilha estaria na célula C10.

Há alguma maneira de fazer isso? Não consegui encontrar uma forma de fazê-lo em minhas pesquisas

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

2 Respostas

2

respondidas 2014-03-21 15:02:17 +0200

imagem do gravatar de Olivier

Você pode NOMEAR os intervalos que serão argumentos da sua função MÈDIA.

Ao nomear os intervalos, eles ficam parametrizados. I.e. quando for mudar de planilha alimentadora, basta ir nos nomes e editar o novo nome. Todas as fórmulas que usam intervalos nomeados serão automaticamente ajustadas.

Por exemplo, dentro da planilha de consolidação, defina um nome para seu intervalo:

Inserir -> Nomes -> Definir nome

  1. Coloque como nome MEUINTERVALO
  2. Selecione o intervalo na planilha alimentadora (E9:E18)
  3. Clique em OK

A seguir, insira no lugar da fórmula MÉDIA = MÉDIA(XYZ.E9:E18)

coloque =MÉDIA(MEUINTERVALO)

Quando for mudar de planilha alimentadora, basta fazer com que MEUINTERVALO aponte para a nova planilha, voltando em

Inserir -> nome -> Gerenciar...

o MEUINTERVALO estará listado lá para ser editado.

editar assinalar como ofensivo Excluir Link mais

Comentários

Ah, bacana! Era essa a ideia Olivier, obrigado!

imagem do gravatar de Elder MarcoElder Marco ( 2014-03-28 13:24:49 +0200 )editar
0

respondidas 2014-03-19 12:46:39 +0200

imagem do gravatar de Beto

updated 2014-03-19 18:30:52 +0200

Caso você mude o nome de alguma planilha o Calc entenderá e mudará automaticamente a fórmula.

Mas, você também pode usar o colar especial e vincular células das planilhas em outras.

É só fazer um Ctrl+C e Ctrl+Shift+v e escolher a opção vincular.

Abraços,

editar assinalar como ofensivo Excluir Link mais

Comentários

Olá Beto, obrigado pela resposta!

Mas haverá momentos também em que irei abandonar a planilha e iniciar uma outra nova. Eu gostaria que apenas trocando o campo com o nome da planilha, eu já pudesse resolver tudo. Nesse caso, eu teria que alterar a fórmula se isso não for possível. Daí a minha necessidade em tentar automatizar o procedimento ao máximo possível.

imagem do gravatar de Elder MarcoElder Marco ( 2014-03-19 23:55:38 +0200 )editar

Desculpe, eu não entendi o que você está fazendo, por isso talvez eu não consiga te ajudar...

imagem do gravatar de BetoBeto ( 2014-03-21 14:04:21 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2014-03-18 21:51:17 +0200

Lidas: 3,036 vezes

Última atualização: Mar 21 '14