Pergunte aqui
0

Como resolver o problema do comando copiar de um arquivo para outro ??

perguntadas 2014-05-27 14:58:44 +0100

imagem do gravatar de mafaraco

updated 2014-05-27 15:15:22 +0100

imagem do gravatar de Olivier

Atualmente, usamos o Ubuntu 2 como versão de sistema operacional. Como planilha a versão LibreOffice 4.0 Calc.

Anteriormente, quando criava meus arquivos, utilizava fórmulas, como exemplo a seguir:

1) Fórmula do arquivo original:

 =+$'Origem Dados'.C69+$'Origem Dados'.C70+$'Origem Dados'.C71

ou

   =SOMA($Pagamentos.F69:F86)+$'Descontos e PSE'.B4,

dentre outras parecidas envolvendo células de planilhas do mesmo arquivo;

2) Copiava para o arquivo posterior, com nome diferente do original, porém com nomes idênticos de planilhas e linhas. A cópia, utilizando control C e control V ou Editar e copiar, trazia as mesmas fórmulas. Mas após mudanças na versão do Ubuntu e do LibreOffice, o comando copiar traz todas informações de endereçamento do arquivo, conforme demonstrado no exemplo a seguir:

 =+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C69+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C70+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C71

ou

   =SOMA('file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$Pagamentos.F69:F86)+'file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Descontos e PSE'.B4.

Portanto, na reabertura do arquivo, ocorrem inconsistências do tipo #ERR, ZERA a fórmula, ou depende de alterações das células envolvidas nas planilhas.

3) O que está havendo para tais inconsistências. Desculpe caso tenha, por engano, confundindo nomes, pois trabalho na Gestão Financeira, não sou especialista em TI.

Fico a disposição para maiores esclarecimentos. Grato pela atenção dispensada.

Atenciosamente, Mauro A. Faraco SERPRO - Brasilía/DF - Brasil Fone: 55.61.2020-8042 ou 61.9395-1450 Email: mauro.faraco@serpro.gov.br

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Uso xls porque nem todas pessoas tem o BrOffice, apesar de recomendar baixá-lo, qdo possível. Dependendo da network da empresa não permitem isso, assim como o SERPRO, outras empresas também tem várias restrições (segurança ti) para download.

imagem do gravatar de mafaracomafaraco ( 2014-05-28 15:52:22 +0100 )editar

Agradeço as opiniões dos Senhores.

Entretanto, eu não copio só a fórmula, mas a planilha toda, com várias outras fórmulas, conectando planilhas de nomes idênticos no arquivo. Se quisesse ter trabalho, já tenho uma solução ou plano B, ou seja: após copiar a planilha toda, vou na barra EDITAR, LOCALIZAR, digito todo o endereçamento que veio desnecessário, pois é o mesmo em todas células e substituo por VAZIO. Assim resolve-se o problema, com um plano B. Porém, considero inadmissível no soft, visto o anterior não sofrer deste problema. Novamente fico grato aos que tentaram, mas preciso ter solução prática.

imagem do gravatar de mafaracomafaraco ( 2014-05-28 16:00:01 +0100 )editar

2 Respostas

0

respondidas 2014-05-30 05:51:33 +0100

imagem do gravatar de Grafeno

Olá, Mauro!

Teste as fórmulas removendo os cifrões "$" da frente do nome das planilhas. Assim, a referência não será absoluta e sim relativa. Quando você copiar a fórmula para um novo arquivo não ocorrerá a criação de um vínculo com o de origem.

=SOMA(Pagamentos.F69:F86)+'Descontos e PSE'.B4

Sem os cifrões, a fórmula acima funcionou em meus testes de copiar/colar entre arquivos xls no meu Ubuntu 12.04 LTS.

Atte,
Grafeno

editar assinalar como ofensivo Excluir Link mais
0

respondidas 2014-05-28 03:12:07 +0100

Mauro, se usa LibreOffice porque o arquivo xls? Só curiosidade....

Control C e Control V ou Editar e Copiar, copia todas as informações da planilha.

Tente fazer a cópia da fórmula diretamente da "Barra de Fórmulas", deste modo você só copia o texto.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2014-05-27 14:58:44 +0100

Lidas: 1,353 vezes

Última atualização: May 30 '14