Pergunte aqui
0

Como calcular a média em um intervalo crescente - calc

perguntadas 2014-06-22 21:06:07 +0200

imagem do gravatar de José Eduardo

Ola pessoal. Gostaria de saber com calcular a média de um intervalo que não é fixo (que vai crescendo mês a mês) conforme o modelo em anexo. Todas as célula contém referências a células de outras planilhas (de jan. a dez.) Gostaria que apresenta-se a média dos meses preenchidos. Utilizo o Rwindons XP SP3 e Libre Office 4.2.3. Grato pela ajuda.

C:\fakepath\Média.bmp

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

3 Respostas

1

respondidas 2014-06-24 01:56:18 +0200

Melhorando: MÉDIASE(mes1:mes12;">0")

editar assinalar como ofensivo Excluir Link mais
1

respondidas 2014-06-23 23:27:38 +0200

Exemplo: SOMA(mes1:mes12)/CONT.SE(mes1:mes12;">0")

Considerando que só terá números positivos.

editar assinalar como ofensivo Excluir Link mais

Comentários

Olá Gilberto, boa, deu certinho, solucionou meu problema. Grato

imagem do gravatar de José EduardoJosé Eduardo ( 2014-06-24 00:29:52 +0200 )editar
0

respondidas 2014-06-23 13:39:42 +0200

imagem do gravatar de Beto

No meu basta colocar algo como: =MÉDIA(C1:C20 )

E fico tudo ok, mesmo nas células com referência a outras.

editar assinalar como ofensivo Excluir Link mais

Comentários

Olá Beto, eu já fiz assim mas ele calcula a média dos 12 meses (divide por 12) e não do período que tem valor acima de zero (células preenchidas). No caso do exemplo seria até o mês de junho. (dividido por 6).

imagem do gravatar de José EduardoJosé Eduardo ( 2014-06-23 17:37:21 +0200 )editar

a média tem de ser feita com o número de meses não vazios... tem função pra isso sim...

imagem do gravatar de OlivierOlivier ( 2014-06-24 00:38:57 +0200 )editar
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2014-06-22 21:06:07 +0200

Lidas: 838 vezes

Última atualização: Jun 23 '14