Pergunte aqui
0

Erro na formula cont.se

perguntadas 2016-12-05 17:29:41 +0100

imagem do gravatar de arielhm

updated 2016-12-05 17:31:29 +0100

Olá Pessoal, estou com uma dúvida sobre a fórmula cont.se e não consigo achar a resposta na net.

Minha planilha está estruturada da seguinte forma:

A

A1 = 66546 - Cancelado A2 = 45877 - Mantido A3 = 85274 - Mantido A4 = 65624 - Saneado A5 = Promo. 545757 A6 = Promo. 654656 A7 = Promo. 65765 A8 = 54698 - Cancelado

Preciso de uma fórmula que conte quantas celulas estão mantidas e quantas celulas estão canceladas e etc. (Observe que cada linha descrita no exemplo está em uma celula apenas ou seja, na celula A1 está "66546 - Cancelado", na A2 "45877 - Mantido" e assim por diante)

Pensei então em usar a formula =cont.se(A1:A8;"Cancelado"), porque quero contar, no intevalo de A1:A8, quantas celulas contém a palavra cancelado. (e também "Mantido", "Prot", etc).

O problema é que quando aperto ENTER a fórmula resulta em zero. Tentei apertar crl shift enter e nada também. Obviamente zero não é pois a palavra "cancelado" está presente em diversas células.

Por favor, alguém me ajude! Grato, Ariel

editar alterar tag assinalar como ofensivo fechar mesclar Excluir

Comentários

Oi @arielhm, a formula esta certa, porém a informação na célula e mista, numero e texto, deve-se montar o cont.se com uso de selecionar o text após "- ". Eu particularmente teria que pesquisar como montar esta fórmula.

imagem do gravatar de SchiavinattoSchiavinatto ( 2016-12-05 18:05:34 +0100 )editar

1 Resposta

0

respondidas 2016-12-07 01:55:25 +0100

updated 2016-12-07 01:57:17 +0100

@arielhm, solução: a fórmula é =CONT.SE(EXT.TEXTO(A$1:A$8;9;15);"Cancelado") após a digitação não de enter, de Ctrl+Shift+Enter pois é uma fórmula matricial. Não arraste a fórmula, use copiar e colar.

Obs.: Levando em consideração que a informação a contar, sempre comece no nono caractere.

Descrição da imagem


Caso a resposta te serviu, por gentileza, click na bolinha Descrição da imagem a esquerda da resposta, para finalizar a pergunta.

editar assinalar como ofensivo Excluir Link mais
Login/Registrar para responder

Ferramentas de perguntas

1 seguidor

Estatísticas

Perguntadas: 2016-12-05 17:29:41 +0100

Lidas: 368 vezes

Última atualização: Dec 07 '16