Pergunte aqui

Perfil de mafaraco - atividade

2014-06-04 06:03:30 +0100 Medalha recebida  Pergunta famosa (fonte)
2014-05-28 16:42:56 +0100 Medalha recebida  Pergunta notável (fonte)
2014-05-28 16:00:01 +0100 Resposta comentada Como resolver o problema do comando copiar de um arquivo para outro ??

Agradeço as opiniões dos Senhores.

Entretanto, eu não copio só a fórmula, mas a planilha toda, com várias outras fórmulas, conectando planilhas de nomes idênticos no arquivo. Se quisesse ter trabalho, já tenho uma solução ou plano B, ou seja: após copiar a planilha toda, vou na barra EDITAR, LOCALIZAR, digito todo o endereçamento que veio desnecessário, pois é o mesmo em todas células e substituo por VAZIO. Assim resolve-se o problema, com um plano B. Porém, considero inadmissível no soft, visto o anterior não sofrer deste problema. Novamente fico grato aos que tentaram, mas preciso ter solução prática.

2014-05-28 15:52:22 +0100 Respondeu uma pergunta Como resolver o problema do comando copiar de um arquivo para outro ??

Uso xls porque nem todas pessoas tem o BrOffice, apesar de recomendar baixá-lo, qdo possível. Dependendo da network da empresa não permitem isso, assim como o SERPRO, outras empresas também tem várias restrições (segurança ti) para download.

2014-05-28 02:56:13 +0100 Medalha recebida  Pergunta popular (fonte)
2014-05-27 14:58:44 +0100 Perguntou Como resolver o problema do comando copiar de um arquivo para outro ??

Atualmente, usamos o Ubuntu 2 como versão de sistema operacional. Como planilha a versão LibreOffice 4.0 Calc.

Anteriormente, quando criava meus arquivos, utilizava fórmulas, como exemplo a seguir:

1) Fórmula do arquivo original:

 =+$'Origem Dados'.C69+$'Origem Dados'.C70+$'Origem Dados'.C71

ou

   =SOMA($Pagamentos.F69:F86)+$'Descontos e PSE'.B4,

dentre outras parecidas envolvendo células de planilhas do mesmo arquivo;

2) Copiava para o arquivo posterior, com nome diferente do original, porém com nomes idênticos de planilhas e linhas. A cópia, utilizando control C e control V ou Editar e copiar, trazia as mesmas fórmulas. Mas após mudanças na versão do Ubuntu e do LibreOffice, o comando copiar traz todas informações de endereçamento do arquivo, conforme demonstrado no exemplo a seguir:

 =+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C69+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C70+'file:///home/89861310800/Mauro/home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Origem Dados'.C71

ou

   =SOMA('file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$Pagamentos.F69:F86)+'file:///home/89861310800/Mauro/GFACF Controle de Obrigações e Pagamentos 2014.xls'#$'Descontos e PSE'.B4.

Portanto, na reabertura do arquivo, ocorrem inconsistências do tipo #ERR, ZERA a fórmula, ou depende de alterações das células envolvidas nas planilhas.

3) O que está havendo para tais inconsistências. Desculpe caso tenha, por engano, confundindo nomes, pois trabalho na Gestão Financeira, não sou especialista em TI.

Fico a disposição para maiores esclarecimentos. Grato pela atenção dispensada.

Atenciosamente, Mauro A. Faraco SERPRO - Brasilía/DF - Brasil Fone: 55.61.2020-8042 ou 61.9395-1450 Email: mauro.faraco@serpro.gov.br