After installing on Linux, libreoffice 4.1 does not start

I just installed LibreOffice on a Red Hat Linux EL 5. Then when I try to run libreoffice4.1 from the command line, a window appears and it looks like it is trying to load, but then it quickly disappears and libreoffice does not run.

I tried resetting the user profile and even deleting the ~/.config/libreoffice directory completely. That didn’t help.
I also tried reinstalling.

LibreOffice3.4 was previously installed on this machine and worked just fine. I didn’t upgrade but rather tried to do a fresh install. It is a possibility that I didn’t uninstall LibreOffice3.4 completely? I removed all the rpms by hand using rpm -e (for the libreoffice3.4 and libabasis3.4 rpms) so it looks like nothing is left.

I did an install on a different RHEL 5 machine that never had libroffice installed and it runs correctly on that machine. This is what makes me think things are not completely cleaned out on that machine where it doesn’t run. Does anyone know what I missed?

I think you have already answered your question. from the command line I would use RHEL equivalent (I use MINT) of

sudo apt-get purge libreoffice*

then reinstall

I tried the redhat equivalent which was:

yum remove libreoffice4*

I also deleted the ~/.config/libreoffice directory before I reinstalled.

I then installed using the following command from the location of the rpm files.

yum localinstall *.rpm

Still had the exact same issue.

It may be a permission error, although it is impossible to tell without further detail. Try starting LO in backtrace mode as detailed in this thread. Post the results of the backtrace here, unless you can determine the problem for yourself, in which case you need only state what the issue was and how to solve it (for others).