After upgrade from 7.0 to 7.1 LO will not open

I have used LO for six years on Windows desktop computer. I used LO today and when I finished using it I did a routine upgrade from version 7.0 to version 7.1 32-bit. Now LO will not open. I ran modify/repair install, but still won’t open. I uninstalled and reinstalled 7.1 but still won’t open. I ran repair on the reinstall, but still won’t open. There were no other computer updates today.
Finally I uninstalled 7.1 and reinstalled version 7.0.6. Now LO opens and works correctly.Someone should notify LO of this apparent bug on Windows 10 Pro version 20H2 build 19042.1237 32-bit

I have also run into this on two of our computers running LO 7.1.6.2 on Win10 Pro 20H2
Previous version that was working 7.1.5.2 (we have reverted back to this)

3 Likes

Check the precise version of your 7.1
If you installed 7.1.6 continue here:

1 Like

The replies to this post are incomprehensible. Installing 7.1.5.2 was suggested, but the only available versions are 7.0.6, 7.1.6 and 7.2.1 So the comment is nonsensical. Someone else talked about Skia. That is a meaningless word to me. Posters on this forum seem to be of very poor quality, and generally unhelpful. Finally, the forum organization is terrible. When I receive an email reply, that reply does not take me back to my thread, but to some other thread. Crazy! I have to search for my thread to see what is going on, and some replies do not appear on my thread.

I also had the problem upgrading from 7.0.6 to 7.1.6. I had to uninstall and revert to 7.0.6.
Clicking on the icon to start 7.1.6 just does nothing.

Edition Windows 10 Pro
Version 21H1
Installed on ‎27/‎08/‎2020
OS build 19043.1237
Experience Windows Feature Experience Pack 120.2212.3530.0

Same here. Just installed 7.2.1.2 which starts OK

Sorry, I assumed after 6 years you had learned a bit more. But I try it in simple words:

You already found the page for downloads at LibreOffice.org and even read the text on “Available Versions”. Now continue reading 3 further lines (or jump directly to the kast line). Even if you don’t understand anything of the words, try to click on the words “in the archive”.

Now you should see a list of digits.
Scroll down to 7.1.5.2 and click again.
Choose win (found in the bottom line of the table) and then the decision between 32 bit (x86) or 64 bit is yours.

Download and install the found .msi

… or search for a program with better support, where nobody talks of skia or other uncomprehensible stuff.

Thanks MikeC. I had the same problem and just went on the libreoffice download page Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft and installed 7.2.1 which works.

The download page says,
Available Versions

LibreOffice is available in the following released versions:

  • [7.2.1
  • [7.1.6]
  • [7.0.6]
    I have no idea what the archive is about, or if it is in anyway related to the mysterious Skia.

Because I actually estimated you have no clue, i suggested you would just follow the breadcrumbs to the “not available, but existing” Version 7.1.5, instead of interpreting a complex wording like Older versions of LibreOffice (no longer updated!) are available in the archive

But as I obviously can’t help you, besides suggesting a typewriter I follow your idea

and will stop communicating on this topic.

@loyall This is not an answer, please do not create an answer if you don’t have a solution; use the comment icon (looks like a speech bubble. Please read This is the guide - How to use the Ask site?
This leads to the next part, you have not given your operating system so nobody can point you to an exact download.
As @Wanderer says, linked from download page is the archive. 7.1.5.2 is at Index of /libreoffice/old/7.1.5.2/win. You will have to click on your operating system, then whether 32 bit or 64 bit, then language and installation type.

Cheers, Al

Go to libreoffice download page Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft and select and install v7.2.1