Apple Dictation software does not work with LibreOffice

I am using the latest version of Mac OSX (‘Yosemite’ version 10.10.4) with LibreOffice v. (current version). Apple Dictation software (like, for example, Dragon’s ‘Naturally Speaking’ software) turns speech into typed text, and works with all the text editors, word-processing, email software I have installed on my system, and note also does work with the current version of OpenOffice. But, unfortunately, Dictation does not work with the current version of LibreOffice!

When I activate Dictation (by pressing the fn key twice), the small window showing Dictation’s microphone icon appears in all the apps I mentioned except LibreOffice (where nothing happens).

Has anyone had any luck using Dictation with LibreOffice?

It would we a real pity if Dictation cannot be used with LO because it works rather well as a speech-to-text app, and (as I have found) saves a lot of time entering data into Calc SHEETS and Base FORMS (which works effectively when using Dictation in OpenOffice). Any tips or comments from Dictation users much appreciated.

Can not contribute to solution, but can confirm the problem.

LibreOffice Version:
Build-ID: 8a217da6e01cf55a41786945d955ae21741fd47b

Mac OS X Yosemite Version 10.10.5

Same problem as above

A BugReport-81759 exists for this problem. The bug headlines are:

  • comment 28: 4.2 series, including, works correctly; 4.3 + 4.4 suffer from the bug
  • comment 31: Bug occurs following commit 179334dd45828d02e4e323cbdda435963fa3f4a5 (Tue Jun 3 09:04:45 2014 +0300)

    Manual reversion of this commit gives a working Dictation again.
  • comment 39: Still no fix as at 2015-07-08_05:50:48

The root of the problem lies in a change from the use of NSTextInput to NSTextInputClient (Change-Id: I6bce9e91a68014a6ca28bff6a820c27817f9baaf). The change was required because NSTextInput is deprecated in 10.6 (‘deprecated’ means ‘due to be removed soon’). However, the new coding simply is not working - for more than a year now.

(my original, flawed, reply follows):

It’s supposed to work fine under Windows (Jul 17 '14)

Ditto, though not so good (Jan 31 '13)

A few folks here said the problem was Webroot in Yosemite:

…(problem was) Webroot antivirus not allowing it. I
had to go to the Webroot logo enter
then “Pause Secure Keyboard Entry”.
Dictation back up and running well.
Third party AV software causes lots of
problems with Apples.

If this helps then please tick the answer (:heavy_check_mark:).

Thanks for your reply. I am using the ‘enhanced’ version of Dictation that does NOT require internet access. Also, I am not using any third-party AV software on my Mac. As I said, the problem is only with Dictation and LibreOffice.

I finally found a LibreOffice Bug Report 81759.

Enhanced Dictation, OSX 10.9.4, works correctly (Bug CONFIRMED with LO (2014-12-12 17:48:39 UTC)

Manually reverting 179334dd45828d02e4e323cbdda435963fa3f4a5 gives working dictation again on current master.

(still no fix)

Thanks Alex. I will mark your comment a helping me, although it seems the problem is NOT solved (yet) because it appears to be a bug in LO. I will wait for a fix and will report back here if there is one!

I can confirm that Dictation works with OS X 10.11 “El Capitan”. I am Using LO Version:
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261