Please please please please please tell me what special kind of idiot thinks that having a default setting to automatically style quote marks is a good idea in a formula based program?

What is your question? An enquiry about design decision or a request for a workaround?

Every design decision is made based on wishes of users, and on current perception of UX people on the ratio between proponents and opponents, and on other considerations like ease of discoverability of the option in question for both groups.

Every decision is a compromise; every may be not optimal, and may be reviewed and changed - and there is the bug tracker (where enhancement requests are tracked, too) for that.

But every time I read something like what is posted here as a “question”, I know I am reading something that only a special kind of idiot, who truly believes to know The Ultimate Truth, might write.

  1. just look around, there might be an option to change it as you wish to have it,
  2. please learn to ask in an appropriate gentle manner, you will surely get better answers …

Every design decision is made based on wishes of users

Every? Really? Show me the user(s) whose wishes were behind the notorious Personal label in pre-7.0 builds!

@gabix: That was not a design decision, but marketing. Please don’t throw irrelevant comments.

an architectural decision? I must admit I was concerned when I saw “Personal Edition” – about the future of LO.

@blashrkh: another offtopic comment. There’s a dedicated question for that, not here.

I find the tone of the “question” disagreeable, and disrespects those people who have done so much work to bring LO to where it is today. I first came across this issue years ago copying formulae from Word (automatically changes quotes to curly quotes) to Excel, since then I have been aware of the issue.

Incidentally, in Calc within a formula (starting with =) the quotes don’t appear to change to curly quotes even if the Autocorrect option is set to change them.

When making a new installion of LO on a computer one of the first things I do is: in the menu (of Calc or Writer, it doesn’t matter) click Tools > Autocorrect > Autocorrect Options..., in the window that opens in the Replace tab select the default language of your douments, in my case “English (UK)”, then click on the tab Localized Options and untick Single Quotes and Double Quotes, OK out. This solves the problem for Calc

If I need curly quotes for Writer then I have another option as long as I have the Lightproof Grammar Checker (English) installed, which often comes with Windows installation but otherwise see extension . In menu click Tools > Options in the windows that opens under Language Settings > Writing Aids check that Lightproof Grammar Checker (English) is ticked. In Language Settings > English Sentence Checking under Punctuation tick the box Quotation Marks (and Apostrophe too). Straight quotation marks will be marked with a blue wavy underlineindicating a grammar error, right-clicking will give an option to replace with curly quotes.

Happily, these settings have remained as set by me through multiple upgrades of LibreOffice. Cheers, Al