Calc: active cell not highlighted or bordered

Hi all,

I recently upgraded to Ubuntu 16.04 and Libreoffice got updated too to the following version:
Version: 5.1.2.2
Build ID: 1:5.1.2-0ubuntu1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default;
Locale: en-IE (en_IE.UTF-8)

Everything works fine in Cal, except for the current or active cell: there is no border for the active cell, so it’s very hard to work with it.
I’ve tried downgrading Libreoffice to 5.0.5, but same problem applies there.

I’ve never fiddled with colour schemes and I’ve also deleted my profile data in ~/.config/libreoffice, but to no avail.

Any suggestions please?

Regards
Xserty

Can you please post your video card model (you can take it from lspci -v and the exact numbers from lspci -n) and your video driver (also from lspci -v) please?

Did you turn off ‘Use OpenGL for all rendering’?

Edit with respect to the comment:
Sorry! I put it wrongly. My intention was to give a hint that an OpenGL issue might be the cause of the malfunction, and to turn OpenGL rendering OFF to get things working better. I have no idea concerning another possible cause…

…except: A corrupted user profile is known to be a possible cause for very strange behaviour of LibO. Try to reset your user profile. Be careful and follow the steps as described here.

Edit with respect to the comments: Sorry! I have no idea beyond this.

The same happens to me. I turned on OpenGL and the active cell gets marked but the UI breaks really bad that I have to disable it again.

Clean profile didn’t help either. It’s weird that OpenGL makes a difference on my system (even if it becomes unusable). [Edit] The OP confirms that clean profile doesn’t help form him either.

I had the same problem too and it turned out that I had a driver issue on my system. I was using modesetting+vesa+fbdev but my X.org intel driver was missing. Reinstalling the xserver-xorg-video-intel driver helped. You can find further information in a bug I raised against LibreOffice, where other testers couldn’t reproduce the problem:

https://bugs.documentfoundation.org/show_bug.cgi?id=99705

Thanks alvarezp!
This was actually the problem! Or should I say the solution to the problem!
Regards,
Xserty

Hi, thank you to all that contributed.
I can confirm that inmy particular case, fiddling with OpenGL options fixed the active cell border issue, but rendered the whole Calc unusable and unstable.
I’ve found that the solution provided by alvarezp resolved the problem completely.
Thanks again alvarezp! :wink:
Regards,
Xserty

Unfortunately i’ve got the same error and

sudo apt-get install --reinstall xserver-xorg-video-intel

and rebooting did not help :confused:

Activating OpenGL Rendering brings back the Active-Cell-Border but destroys many other Elements. Any Ideas?

I have the same problem on Ubuntu 16.10 for Calc 5.2.5.1 .

This bus appear in libreoffice 5.1.2, 5.1.6~rc2, 5.3.3~rc2
Xubuntu 16.04.2
aptitude reinstall xserver-xorg-video-intel-hwe-16.04
did not help

This is not an answer. It’s more of a Me Too!
Dual Core intel 2ghz running Ubuntu 16.04 LTS. I followed the advice to use the intel graphics update tool. This did not resolve the issue. Running Libre Office 5.1.6.2

This one silly issue is making it exceedingly difficult to complete a migration off of windows.

Thanks for any advice.

2017-07-28: I am happy to see that the marking bug of LibreOfficeWriter and LibreOffice Calc has vanished today after my last system update which involved switching

  • from Linux kernel 4.8.0-58-generic
    x86_64
  • to Linux kernel 4.10.0-28-generic
    x86_64

plus a bundle of other upgrades.

Try using LibreOffice version 6.2.8, but NOT 6.3.1 or 6.3.2! See my bug report here: https://bugs.documentfoundation.org/show_bug.cgi?id=128406

Here is a workaround.
Set all the cell borders to light grey for the default cell style.
The active cell will have black borders and can be seen clearly (even on high resolution monitors)

image description