Calc COPY function seems to be broken under Windows 11

I had been running LibreOffice 6.4.4 on Windows 10 and even on Windows 11 with no problems. I am using the “S-mode” of Windows which means I only run software obtained through the Microsoft Store.

Earlier this year. Microsoft pushed the 22H2 release of Windows 11 onto my system. I noticed immediately that when I now tried to use my mouse to copy cells, Calc would “lock up”. Observing with the Windows Task Manager performance monitor, I saw that memory usage for LibreOffice would start increasing but Calc would never come back. I have tried copy/paste in other apps and have no problem. I reverted Windows to the previous level and tested and everything was back to working. A few weeks later, Microsoft pushed the same 22H2 release to my system and again I had the problem. I obtained and installed the LibreOffice (x64) level thinking maybe there was something in the older release that wasn’t compatible with Windows 11 at the 22H2 level. Did not help.

Since my system only had 4 Gb of memory, I thought maybe I was encountering some paging/swapping issue which the new Windows level was creating. I upgraded my memory to 16 Gb. Did not help.

Tried to find informatoin in Ask Libre and have not found anything. I am at a loss and open to suggestions on how to proceed. Thanks in advance for your help.

I did find an item in Bugzilla which seems to describe the same problem.

I would be inclined to Restart Windows then in Control Panel\All Control Panel Items\Programs and Features right click LibreOffice and select Repair.

Check if OK, if not then check in LibreOffice safe mode, Help > Restart in safe mode > Continue in Safe Mode and check there, there might be more than one issue.

Windows 11 has a new Clipboard Manager which some people find does not play nicely with LibreOffice or OpenOffice - go to Start > Settings, Click Clipboard on the System tab and turn off Suggested Actions; if that doesn’t help, try turning off Clipboard History


Google is obviously better suited, especially as other sources are available:

The information is the same as given by robleyd

1 Like

Hmm. I have Windows 11 and have Clipboard history turned on but I never see these clipboard problems, maybe because I always log on locally and never, ever with a Microsoft account. Sharing the clipboard, mentioned below, is not available to local accounts.

I wonder it might occur if you log into Windows with a Microsoft account AND you enable Clipboard History so it will try to share the clipboard across all the devices on that Microsoft account.
If I read the help page, Seamlessly transfer content between your devices - Microsoft Support I see this Q&A which might be the start of a problem:
Q: Does what I copy on one device get added to the other device if I don’t paste it here?
A: Every time you copy something on either device, what you copy will replace the clipboard content on both of your devices.

That looks like it has potential for an endless loop or a delay while it tries to find/wake the other device(s) on the network.

1 Like

Thank you. I turned off both options you suggested and LibreCalc Copy works find. I did not try it with just Suggested Actions because I can’t see a reason for me to keep a history. Again, thank you for response and getting me back up and Copying.