Calc text import not working correctly


I am trying to import this text file - but it doesn’t seem to work correctly.

Can you please help?

Can you provide more information: Version of LO. Sample data from the file (but no private information). What you’ve tried so far. Date fields can give mixed results. What type of file or format of the file you are importing – CSV, TAB, etc.

Hi ,

I’m using LO
I have enclosed the file.
I tried to import it - so far the best result I have achieved is by ticking the “TAB” “SPACE” and merge delimiters boxes.
But even then it is not perfect.
Excel seems to handle it fine.

Please verify activating the option for Detect Special numbers, also you can select a column a set up the proper type in column type box. Maybe select properly the Character set and Language can help.

I did try that but no joy I’m afraid.
Excel recognises it as an MS DOS (PC-8) format and translates it well.
This is quite critical as it means I will have to upgrade more desktops to Office2013 and I would rather not do that.

Also, the way Excel handles these imports is really nice - you can also during the import join 2 columns making it easy to create a result you desire. How can I request this as a feature in LO?

Please, can you paste here a couple of lines of the CSV file. Of course change the text of any confidential information.

Item Number Description Customer Name Order Sch Quantity Required

550116859001 SEALKIT PLUS WASHER 00600109 AGCO INTERNATIONAL GmbH(FR SO645934 Fin 18.0 13/01/14
551101326210032 MOTOR 16.8LC SW.VALVE SNM2 VITON SHAFT SE 00603001 Alexander Dennis Ltd (Prod SO627694 Sch 14.0 13/01/14
550LG32890002 SEALPACK 32890 00600109 AGCO INTERNATIONAL GmbH(FR SO646113 Fin 9.0 14/01/14

I thought I had enclosed the file - but I can’t seem to see it - I have copied and pasted the first few lines - but I’m not sure this will help you much - so I have uploaded onto The link is here - it is a text file called mfg9_8.txt. Thanks for any assistance you can offer me.

You can use the 101010 icon to send it as code. Your text doesn’t have quotes neither commas, and doesn’t seem the space is the separator.

Thanks for the tip Mario. The file is a combination of TAB and spaces as delimiters by the looks of things.

Then try using only tabs as separators. If it is a CSV file only one separator must be used.

Thanks I tried that earlier - I think I’ll have to give up on this unless LO decide to support the MS DOS (PC-8) format and also enable one to merge columns on import like in excel