Cannot open BASE files

Cannot open BASE files. Message appears that I must have Java. Having read previous answers I made sure I have newest Windows 10 x64, using only IE as browser and check to see that it recognizes Java, I have latest 64bit LO. Still cannot open BASE file for same reason (other modules work fine). Please help me to use these important files.


The Java required by Base has nothing to do with what the browser sees. For the required Java see my answer in this post → on firefox and have loaded java 32.

It also appears you are trying to connect to existing Base files. If these are connected to Access DB, please see this post in addition to the above → I got error “The connection to the data source “DB file name” could not be established.”.

If this answers your question please tick the :heavy_check_mark: (upper left area of answer). It helps others to know there was an accepted answer.

Thank you. I followed your links to Oracle & downloaded & ran the JRA installer jre_10.0.1_windows-x64_bin_exe. Upon a reported successful installation I ran LO (version (x64)). The outcome was unchanged. I checked Tools->Options->LibreOffice->Advanced, and it reported that the 10.0.1 version was properly installed. I closed all and did a Restart with no change in outcome

@aschold Your comment here is proper. Deleted the answer as it is not an answer to the question.

Have recently seen a couple of others on Windows with same claim using Java 10. My response - Try Java 9 (my neighbor is using 8 and is working). If that works, report the Java 10 problem on Bugzilla.

So far no one has responded. Please report back as to what the result was.

BTW, Java 10 works on Mint 18.3 and no problems.

Thanks, I didn’t know how to respond to the original answer - no Reply tab. Anyway, I will look for Java 8 or 9. Very frustrating as I really need those datebases created with LO originally

Java says now that v.10 is out v.9 is no longer available. Also like to hear back from the individual who answered first. Oh yes, none of my Base files were created with Access.

Don’t know why 9 isn’t available since you can still get 6 or 7 or 8 - maybe 9 was a big problem. As stated in previous comment neighbor is successfully using 8. Same location → Java SE Downloads, just scroll down a bit.

OK, thanks, I will give it another try.

Found and installed both versions 8 and 9. Eight works; 9 does not. I will report on Bugzilla. Thanks a lot

Finally an answer back on the subject! Thank You! Please post here the Bug report # for reference.

Very glad you have something working.

P.S. - I try not to do Windows.

I followed this topic as I had the identical problem in Windows 10 64 bit! I downloaded and installed JRE 8u172 and it solved the problem. I did not need to uninstall the latest version which apparently caused the problem.

@hollrm FYI, you can have many different JRE/JDK versions installed without affecting Base. Base will only use the version which is selected in Options. OpenJDK is also another possible alternative.