Can't remove unwanted page break before table

In my text I have a number of paragraphs, then a table, then another paragraph and another table. The second table insists on positioning itself on a new page. Like so:

Paragraph
Paragraph
End of page
Start of page
Paragraph
Paragraph

Paragraph
Paragraph
[TABLE 1]
End of page
Start of page
Paragraph
(lots of empty space)
End of page
Start of page
[TABLE 2]
Paragraph
Paragraph
…etc.

No matter what I do, I cannot get the second table to move up. A small amount of text follows the first table, then the rest of the page is empty, and the second table is positioned on a new page. It’s as if I’d hit Ctrl-Enter to insert a page break, except I haven’t and there is no page break there, or if there is it is invisible and can’t be removed. If I hit delete after the final paragraph before the table, the cursor will simply position itself into the first table field.

What am I missing?

Maybe the table has disable ‘Allow table to split across pages and columns’. [right-click]/Table properties

image description

Why not?, Pls add a comment to the answers or edit your question, don’t add new answer, when it is not.
.
If the answer solves your question please tick the :heavy_check_mark:.

It does. Should it or shouldn’t it?

To Delete a Manual Page Break That Occurs Before a Table

Right-click in the table, and choose Table.
Click the Text Flow tab.
Clear the Break check box.

This is from Inserting and Deleting Page Breaks - LibreOffice Help