Can't sql insert into table in sql tool screen

Because it might be related: I have Mac OS 11.1 Big Sur, JDK version 15.0.1, and LibreOffice

I’m a newbie here. Things all seem to be working fine so far, except Base sql insert into MyTable can’t find MyTable.
Error: Table not found in statement [insert into MyTable …]
Doesn’t matter if I’m using a values clause or a select clause for the input. Same error. It does find the table if I select from it.

I was just playing trying to learn my way around and it’s really weird that when data is imported into a base table it always shows up bold (data formatted?) but if I insert by hand it isn’t. The data is not bolded in the source Calc table. Anyhow, that’s how I ended up trying to insert (I was curious if the resulting data would be bold).

Thanks for any help.


You don’t state the database you are using nor the actual SQL. Best guess here is that you are using HSQLDB embedded for the database and the table name is mixed case.

If so, the table name (also applies to field names) needs to be surround with quote marks:

Update "Table" Set "myField" = 'something'

You may also want to look at these posts regarding Big Sur:

Is Libre Office compatible with Mac OS Big Sur?

Mac User Learning Base receive message that JRE is defective

I am using HSQLDB. I did not know the quote-marks–for-mixed-case rule so thank you. I had actually tried a lot of variations of the same query, sometimes with quotes, sometimes with field names specified, etc. In any case the basic query was
insert into testledger select * from testledger2
I, uh, had no problem running it today changed to
insert into “testledger” select * from “testledger2”
(could’ve sworn I tried that, oh well).
I’ve noticed some other weirdness from a couple of days ago has also gone away. shrug
In any case, THANKS!