Como referenciar uma planilha a partir de uma célula?

Olá,

Estou com o seguinte problema. Tenho várias planilhas criadas em um documento do Calc. E uma outra planilha que tem o objetivo de resumir com resultados os dados presentes nessas planilhas em uma única tabela. Assim, por exemplo, para gostaria de calcular a média de todos os valores num dado intervalo de colunas da planilha XYZ e colocar esse valor em uma célula de outra planilha, no mesmo documento. Eu poderia fazer:

= MÉDIA(XYZ.E9:E18)

No entanto, se eu mudar o nome da planilha por algum motivo, terei que alterar a fórmula também e algumas são mais complicadas. O nome de cada planilha é colocada em uma célula dentro dessa planilha onde quero salvar os valor médio e gostaria de referenciar essa célula, por esse valor. Seria algo do tipo (que não funciona)

= MÉDIA(C10.E9:E18)

Onde o nome da planilha estaria na célula C10.

Há alguma maneira de fazer isso? Não consegui encontrar uma forma de fazê-lo em minhas pesquisas

Você pode NOMEAR os intervalos que serão argumentos da sua função MÈDIA.

Ao nomear os intervalos, eles ficam parametrizados. I.e. quando for mudar de planilha alimentadora, basta ir nos nomes e editar o novo nome. Todas as fórmulas que usam intervalos nomeados serão automaticamente ajustadas.

Por exemplo, dentro da planilha de consolidação, defina um nome para seu intervalo:

Inserir → Nomes → Definir nome

  1. Coloque como nome MEUINTERVALO
  2. Selecione o intervalo na planilha alimentadora (E9:E18)
  3. Clique em OK

A seguir, insira no lugar da fórmula MÉDIA
= MÉDIA(XYZ.E9:E18)

coloque
=MÉDIA(MEUINTERVALO)

Quando for mudar de planilha alimentadora, basta fazer com que MEUINTERVALO aponte para a nova planilha, voltando em

Inserir → nome → Gerenciar…

o MEUINTERVALO estará listado lá para ser editado.

Ah, bacana! Era essa a ideia Olivier, obrigado!

Caso você mude o nome de alguma planilha o Calc entenderá e mudará automaticamente a fórmula.

Mas, você também pode usar o colar especial e vincular células das planilhas em outras.

É só fazer um Ctrl+C e Ctrl+Shift+v e escolher a opção vincular.

Abraços,

Olá Beto, obrigado pela resposta!

Mas haverá momentos também em que irei abandonar a planilha e iniciar uma outra nova. Eu gostaria que apenas trocando o campo com o nome da planilha, eu já pudesse resolver tudo. Nesse caso, eu teria que alterar a fórmula se isso não for possível. Daí a minha necessidade em tentar automatizar o procedimento ao máximo possível.

Desculpe, eu não entendi o que você está fazendo, por isso talvez eu não consiga te ajudar…