CONVERT-TO on Windows Not Working

I have tried to execute this command convert-to many times without success. I am trying to convert a word doc to pdf. I have tried other formats but have yet to get any to work.

The batch command window stays open. I need to terminate using windows task manager.

I am using windows 7 and libreoffice 3.5. I have tried libreoffice 3.6.

“C:\Program Files (x86)\LibreOffice 3.5\program\soffice.exe” --headless --convert-to pdf --outdir C:\convertTest\ C:\convertTest\l06.doc

Hi @Thumper, As @Pedro1 mentions below, this is probably a bug. Please file a bug here. The QA team will be happy to help you track down this issue! Thanks!

If you remove the ending \ in the outdir path i.e. to C:\convertTest it does work

(at least it does under Win XP x86 SP3 using LO

This is probably a bug and needs to be reported…

Here’s a link to the Bug submission Assistant. Please provide a list of steps that can reproduce your bug.

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.


Maybe helpful:

Tags, matching "convert-to"

Thank you for your help. The command executes and ends, but no file is made. I tried another windows 7 box, same issue.

I tried a doc to PDF and doc to txt, still no file created.

@thumper, I also had success by opening a “terminal window” and navigating to C:\Program Files (x86)\LibreOffice 3.5\program and from there executing soffice.exe --headless --convert-to pdf --outdir C:\convertTest C:\convertTest\l06.doc. Maybe worth a shot?

Good idea, but that did not work either. The command executes, no errors or other messages are displayed, but no L01.pdf was created.

It’s working for me in win7, LO

Close LO first.

“C:\Program Files (x86)\LibreOffice 3.5\program\soffice.exe” --headless --convert-to doc --outdir “D:\output folder” “D:\input folder\input file.html”

this did work for me, thanks. (using LO on win7 64bit)

looks like outdir is necessary, and wildcards (*) are NOT supported. (use a for loop instead)

see: Convert-to command line parameter - #14 by rafik