Copy paste heading 3 and table , pastes to new page

copy paste heading 3 and table

heading 3 ; disabled paragraph type text flow all options

table: table properties text flow disabled all: break, split, keep next, repeat heading

copy an existing h3 and table, and past below it >> pastes to the next page, ie creates a page break

clear formatting on the pasted h3

delete at start of h3 line - shifts it up a page to immediately below the table it’s supposed to follow

reapply h3 style to the heading text

and now it is where is is meant to be

multiply that 20-100 times a day….

{EDIT content in Answer; attached here by floris v}

Mac OS 12.5.1 LibreOffice 7.3.4.2

Only working within LO. No paste involved
Impossible to tell if page break; the help I looked at did not clarify: I only see the same pilcrow character

attached file exhibiting the issue with heading 4 ( with/without a line after the preceding table
A4

heading_page_break.odt (20.1 KB)

thanks for looking at it

Keeps you busy … You didn’t even ask a question. So I will ask you:
.
You copy just inside an odt-file? Or from some website? You are absolutely sure there is no page-break in your copied source?
Then the usual question: Wich LO-Version on wich OS, wich settings (page-size).
.
If you expect somebody to check on your topic it increases the probability, if YOU provide a sample document with heading and table and upload it here…

1 Like

The page break in the H4 is direct formatting. You can see it when you click in the heading, then Format - Paragraph - Text flow tab.
Please read the “how to survive here” aka This is the guide - How to use the Ask site?. We prefer that you edit your question to add information. An Answer is supposed to contain a solution, it will suggest to visitors of this board that they don’t have to step in to help anymore because somebody already offered help. Please remove your “answer”.

2 Likes

In addition to @floris_v fundamental remark, you abuse Default Paragraph Style. This style is the basis for all others and should be used only to set attributes shared by all other styles. The “standard” style for text is Text Body.

In your tables, mainly in the JSON descriptions, you use tab characters to align vertically the semicolons. Unfortunately you rely on the evenly spaced default tab stops. This is bad because you need a variable number of tabs depending on the width of text elements (for example one tab after “category”, two tabs after “type”. This is semantically inconsistent because, logically, tabs separate fields. You create a spurious empty field (which could cause loss of synchronisation if your text is scanned by some automated tool). Instead you should create a dedicated paragraph style with ad hoc tab stops. Later, this facilitates document maintenance.

@qubitq,
Please, check the H4 paragraph break settings before copying.

<<heading, then Format - Paragraph - Text flow tab.>>

that’s what I have been missing, thanks

the tab issue is a product of copying from the source code and pasting in
The source itself can’t manage to to display the same alignment in two sequential edit level views of the same parameter set. Pasting that into LO introduces a third level of tab irregularity.

The variable number of tab stops is my fix to alignment. I am not aware of another way of doing it.

had I been able to find the edit button, which remains un-identifiable, I may have.
I had intended to reply, but that was also unidentifiable; the text flags on the buttons don’t always raise