Dar valores específicos por estágios de números

Tenho uma tabela cujo preciso que me de valores de 100, 160, 220, 280 ou 340 dependendo de outro numero que varia
Quero que fique assim:

se c18 < 10; 100

se c18 = > 10 e ao mesmo tempo c18 <14; 160

se c18 = > 14 e ao mesmo tempo c18 <18; 220

se c18 = > 18 e ao mesmo tempo c18 < 22; 280

se c18 = > 22 e ao mesmo tempo c18 < 26: 340

Utilize a função PROC. Veja a imagem.

Descrição da imagem

Neste caso, se o valor de A7 for menor de 14, a resposta é N/DISP. Você pode colocar uma função SE.É.NÃO.DISP() na frente pra tratar o caso.

Se for maior que 23, retorna 340.

Se não quiser usar a tabela A:B, podemos escrever a fórmula da seguinte forma:

=PROC(A7;{14;18;22;23};{160;220;280;340})

onde as matrizes {14;…} e {160;…} podem ser digitadas diretamente na barra de fórmulas

Ótimo, @ohallot sempre um Mestre. E no caso é só esconder a linhas (se necessário).

Obrigado @Beto… adoro desafios e esse me fez coçar a cabeça para evitar a cascata de SE() que encontro dia sim, outro também (não por que esteja errada, mas é de difícil legibilidade).

Oi @ohallot, gostei desta alternativa, já anotei no meu caderninho de ajuda. Mas para a solução do @Sypom não é viável, se tiver que criar tratamento de erros !!!

Fiz um teste aqui, ficou meio grande mas deu (acho) o resultado que vc quer. Veja o arquivo: se_Valores_ask.ods A fórmula está em A1 e o número a ser digitado em B1.

Muito obrigado, exatamente o que eu precisava, show!

Bom que serviu, @Sypom, por favor, assinale a minha resposta, ok?

Oi @Beto, rever fórmula valor 26 não é 340. Conforme enunciado de @Sypom “se c18 = > 22 e ao mesmo tempo c18 < 26: 340”

Olá, @Gilberto exatamente, seria “0”, mas quis “pegar” o 26, pois entendi que ele queria isso. Mas enfim, a ideia é mostrar um jeito de funcionamento da Função SE(), para que ele adapte a necessidade dele. Como sempre falamos: ‘Há muitas maneiras de resolver’. Caso ele fique com alguma dúvida ou não tenha servido é só ele perguntar de novo e inclusive atentar para o seu comentário. Obrigado pela observação.

Fácil, use =SE(C18<10;100;SE(C18<14;160;SE(C18<18;220;SE(C18<22;280;SE(C18<26;340;"?")))))
E complementei com “?” caso for faixa a partir de 26.

Assim fica mais simples, né Gilberto? É só (a fórmula) ir na ordem crescente dos valores. Abraço.

Sei que já foi respondida e atendeu à necessidade. Mesmo assim, complemento:
Não precisa usar condições pra fazer isso. Elas ocupam mais recursos do sistema do que cálculos simples.

O resultado que você quer pode ser obtido pela seguinte fórmula:

= 340 - ( ( C18<22) + (C18<18) + (C18<14) + (C18<10) ) * 60

Minha única dúvida é: E se a área foi maior ou igual a 26m², qual potência deve ser utilizada? 340?
Se é isso, não precisa alterar a fórmula.