Default ODT page size created in Windows Explorer

When I create a new file from Windows Explorer

  • right-click
  • New
  • OpenDocument Text
    and then open it in LibreOffice (3.6rc1) it is always in A4 page size, although my locale is set to English (US) and new Text documents created in LibreOffice are Letter size.

What gives? How can I change this? I’m sure Windows won’t give me an option.

Windows does give you an option in a way, as the documents you can create via the explorer’s context menu are just real documents that are copied over to the current directory.

So when you want to change them, create an empty document with the settings of your liking and then replace the shell-new copies that were installed by your document.

The boilerplate documents are in windows\shellnew

Note that if you want to add it as additional option, you also need to add a registry key, see for instructions

Is it work exploring how to make this created template match the OS locale? Is this something LibreOffice can fix?
(I’ve used both Win7 and Win8CP to test this)