Dialogo não mostra imagens

Alguém saber explicar o que esta errado ou é bug ? Uso Win7(64) + Libo 6.0.4.2(x64)

Edição do Dialogo

¿Alguien sabe explicar lo que está mal o es un error? Uso Win7 (64) + Libo 6.0.4.2 (x64)

Edición del diálogo

Visualização com Caixa de dialogo de visualização

Visualización con cuadro de diálogo de visualización

Minha macro:

Mi macro:

'====================================================================
Sub ExecutarMiDialogo
'====================================================================
Dim oDialogo As Object
Dim oDialogoModelo As Object
	DialogLibraries.LoadLibrary( "Standard" )
	oDialogo = CreateUnoDialog( DialogLibraries.Standard.getByName("DiaMenu") )
	oDialogoModelo = oDialogo.getModel()
	With oDialogoModelo 
		.PositionX = 20					'Posição a partir da esquerda.
		.PositionY = 20					'Posição a partir do topo.
	End With
	Beep	
	oDialogo.execute()
	oDialogo.dispose()	
	Beep
End Sub

Executando a macro as imagens não estão visíveis.

Ejecutar la macro las imágenes no son visibles.

Salvando o arquivo, na abertura na edição as imagens sumiram…

Salvando el archivo, en la apertura en la edición las imágenes desaparecieron …

Será que é bug.… se usar selecionar não mostra o caminho da imagem. Mas se colar o endereço da certo.

A T E N Ç Ã O… Descobri agora, se colar o endereço a imagem não é incorporada ao arquivo.E quando e feito pela seleção […], mesmo que apareça , nada acontece. Alô @ohallot, qdo tiver um tempinho de uma investigada em Bugs. Grato.
/// Descubrí ahora, si pega la dirección de la imagen no se incorpora al archivo.Y cuando y hecho por la selección […], aunque aparezca , nada sucede.

Olá @Gilberto

Numa oportunidade similar eu cheguei a desenvolver este trecho, onde a imagem era carregada pela macro. Não sei dizer se o problema encontrado é bug ou não (parece que é).

Note que getExtensionLocation() e imageFile apontam para o arquivo da imagem.

' coloca a logomarca da empresa

	oModeloDlg.getModel().ImageControl1.ImageURL = getExtensionLocation() & "/" & imageFile
	oModeloDlg.getModel().getByName("ImageControl1").ScaleMode = com.sun.star.awt.ImageScaleMode.ISOTROPIC

Dentro do procedimento da sua sub ou function, use:

(…)

With imgServidor.getModel ’ (imgServidor = dlg.getControl(“imgServidor”)
ImageURL = ConvertToUrl(Disco:\Pasta\Arquivo.jpg")
.ScaleImage = True
End With

(…)

Ops… Obrigado !

Funcionou pela segunda tentativa, criando uma nova guia de planilha e inserindo a imagem.

Obrigado !

Sou muito novo ainda em Libreoffice porem consegui contornar essa situação da seguinte maneira…
Fiz todos os caminhos ai descritos na colocação de imagem na Caixa de Dialogo, com a imagem incorporada e tudo.
Porem para poder aparecer novamente depois que salva é necessário fazer uma nova quia da planilha com as imagens que elas apareceram após o salvamento.
Provavelmente deve ser um bug mesmo.

Sensacional, @Donini, valeu a dica.

O visual das planilhas vão melhorar.