Disable Calc automatically selecting a cell when clicking out of another cell

How do I disable Calc selecting a cell reference, after clicking into a cell with a formula and then clicking out? I just want to get out of edit mode, not add the new cell reference to the current cell with the formula.
A1 has a formula in it. I double click in A1 to see which cells are being referenced (easy to see). I then click any other cell (e.g. B4), however now Calc has added B4 to the formula in A1.
I just need it to select B4.

Just press Esc key.
Or click in the green check mark at the left of the input line.

EDIT: If no changes were made to the cell, both Cancel (the multiplication like x red sign) and Accept (the green check mark) would do the same: exit edit mode.


Thanks LeroyG, however on large spreadsheets that’s a lot of extra clicks and needs two hands. I understand some may like this feature but I just want to click outside the selected cell.

Actually, to hit the top left button Esc, you need one hand …

Okay, I’ll offer other options:

  • select a cell with one click and read the formula not in the cell, but in the formula bar - in this case, clicking on another cell will not change anything.

  • before examining the sheet, set the protection - this will give the result you expect

1 Like

Thanks JohnSUN. Unfortunately it seems the short answer to my questions is no.

You can write a macro to simulate the pressing of the Escape key. Then you can assign that macro to a custom toolbar/menu entry. The new main menu item “Virtual_Keys” contains two new items: MyEscape and MyReturn. And the macros are assigned to the Standard Toolbar too (without usage any Icons)

Here is a sample file what contains tha macro and the assignation of the macro (it works in this document only). Result: you will able to exit the cell edit mode by one (or two) mouse click - “without your another hand”.

MyEscape.ods (15.1 KB)

Sources and additional informations:

There is no need to duplicate buttons. You already have them (Cancel and Accept) to the left of the input line. See the screenshot in my comment.


Oooops! They are colorized, but I never noticed and I never used them… The Enter key and the Esc key is more comfortable for me.