Doc files open as read only

My doc files open in libreoffice write as read only, and I have not been able to find any way of editing them. “Help” said to use the “edit” button, but that doesn’t give me the availability. I still get the message, “Readonly content cannot be changed, no modifications will be accepted.” I tried “save as” with a different name, but it still opens as “read only”. I need more help.

What is your Operating System and LibreOffice version?
Where you open the files?.

I have the same problem. I am using Mac OS X 10.8.2 and Libreoffice Version (Build ID: e29a214)
It seems as if I write a new document, save it, and do not look at it for several weeks, it converts itself to Read only. I can find no way to change it back, and as the original poster noted I can find nothing in the Edit menu that helps. (The Help document says “Use the Edit File icon to activate or deactivate the edit mode.” but I can find nothing there that does anything useful.)
Can someone please tell us what is happening and how to correct it?

I’m Mac OS 10.15.4 and having the same issue with read only. Is this a Mac Security issue? I’ve just installed 7.0, but it was happening on the previous version.

Hi @Karl1,

As you’ve already mentioned, the Edit Button can be used to allow editing of Read-only documents. There’s a much better explanation (with pictures) of how it works here:

There are a number of different things that could be going wrong on your system. Could you please grab a new build and see if the problem still exists in the newest version of LO? Thanks!