Does 'Restart numbering' have any effect on endnotes?


I am trying to re-start the numbering of endnotes for each chapter of my thesis. All the endnotes need to collect at the end of the document (not the end of different chapters or sections) and they also need to re-start at 1 for each chapter. (This is required by my style guide. It is also a common format for books.) I can right-click on an endnote and click ‘Restart numbering,’ but nothing happens. Does this functionality simply not work? Am I missing something?

I’m using a recent version of Libre Office (3.5.0). I’ve tried in Windows and Ubuntu. I really want to make this work for my thesis.

Any help would be much appreciated.

As for alternate ways of solving this problem, there are a couple discussed in a previous post of mine. Unfortunately no solution yet that works for my situation / style of endnotes (except to write a custom script, which I doubt I’m capable of) :

Thanks so much if you can help,


Basically a dupe of: Is it possible to number endnotes by chapter?

Yes, there’s a lot of discussion on the other question, but perhaps all discussion should be combined (even if Askbot isn’t the best tool for large/threaded discussions)

Worry not brother, LO to the rescue.

Go to Tools > Footenotes/Endnotes

In the Footnotes/Endnotes Settings dialog box, under Footnotes tab, change Counting to Per chapter and you’re all set to go. Just make sure you are using Heading 1 style for your chapter titles, which I’m quite sure what you are using now.

I hope this is what you wanted and good luck with your thesis.

As I mention in my answer in your related question there is currently no way to achieve this type of numbering and placement for endnotes. I cannot find an open bug relating to this so please file an enhancement bug and provide as much information about this new feature as possible. Don’t forget to mark your bug as an ‘enhancement’. The QA team will be happy to help you triage your feature request in the bugtracker.

Please post a link to any bugs you file in a comment below using the format “fdo#123456”. Thanks.