Double-click doesn't select the space after a word. Can I change it?

In most GUI-based text-writing tools a double-click selects a word, plus any trailing spaces after the word. This is true of my browser as I type this note, my email client, of M$ products, and of many X-Windows based Linux tools. LibreOffice Write selects only the word, without the trailing space(s). I’ve scoured documentation, but I’m not finding any reference to a Preferences setting. Is it available?

As a side note:
When you double-click a word and cut, this deletes also the previous space (if it is not the first word of a paragraph). This previous space (and its format) will not be pasted with the word itself, but pasting will add spaces before (if needed) and after that word.
Tested with LibreOffice 7.1.8.1 on Windows 7.

Confirmed – that’s the behavior I see as well, and thanks for pointing it out. That’s useful information I had not learned. But for good or ill, it isn’t the behavior of most gui editors in Windows. Is there a setting I can tweak to change it?

You didn’t mention why you need the trailing space. Usually I double-click to get the word selected so that I can replace it by typing. Since I target a word, implicitly including trailing space(s) would force me to recreate the space separator, which I could forget. And when I’m in a preformatted paragraph (with monospaced font), selecting trailing space is even worse because this would ruin the layout.

Don’t confuse selection with “action”. Writer, LO in general, implements “smart copy & paste”. It extends the selection as mentioned by @LeroyG depending on what you request both in the source (copy/cut) and destination (paste) operations.

For the record, in Writer:

  • double-click = select word
  • triple-click = select sentence
  • quadruple-click = select paragraph

I’m just lookin for consistency between Writer, Word (which I have to use at work) and every other editor I use in Windows (including the one I’m using for this answer). In Word overtyping a highlighted word/space maintains the trailing space. I’m not sayin Word is the One True Editor, and I might even look into configuring my copy of Word to match the Writer behavior.

Selecting just the word is all well and good, but it is contrary to every other tool I use and when I’m editing a document, where this first appeared as an issue, I found myself leaving two spaces in words when I did a quick double-click followed by a backspace to delete a word. If Icould choose, I might want the other tools to be configurable to match Writer, but the chances fo getting that are slim. I just want to maintain the muscle memory from one platform to another.

Every behaviour has its own advantages and drawbacks. What I want personally is the “least astonishment principle”. I don’t like at all working assumptions about how I should write my stuff (automatic additions or transformations of what I type). These assumptions are wrong most of the time. In Writer they can be completely turned off and replaced by my favourites (or none). I think this is much more sound then imposing something leading to “muscle memory” and later preventing to quickly adapt to a new suite.

1 Like

I suppose that being “smart” (which Writer already tries to do) implies there’s a possibility to improve: e.g., it might be a reasonable idea for the action (which @ajlittoz highlighted) to distinguish between erasing (pressing Delete or Backspace) and overwriting (pressing a key inserting a character). A reason to file an enhancement request?

1 Like

@mikekaganski, I believe you are correct. I was hoping the solution would be to tweak a Preferences file, but that may be what’s needed is a formal enhancement request to make the behavior selectable. The limited-select is a problem for me when editing – I tend to have to remove words, sometimes singly, sometimes as a group. Overtyping is no problem. In Word, the trailing space is re-inserted, in Writer it is never selected, so the net effect is the same. But simply deleting a word results in a two-space gap where my muscle memory expects the word and any trailing space to be deleted.

@ajlittoz, I believe your “least astonishment principle” is spot on. That’s exactly what I’m looking for.

Off to the Feature Request page.

The Lords of Writer seem to think I have a point.

Bug 149254

Cheers!

cwk