Error: Input required in field from Table

Sorry, the title isn’t all that descriptive. Suggest a better one if you have one.

I’m getting this error with a base application I made a couple of years back. The application is just a bunch of forms, manipulating data from a mysql database.

The field with the required input is defined in the database as nonzero and current_timestamp as initial value (the field is named ‘Created’), so normally this field shouldn’t be mentioned in the 'insert statement for the mysql server thus it wasn’t even present in the Table Control.
Trying to figure out where the issue came from, I tried changing the field in the database, to allow this field to be empty. This didn’t change anything leading me to the conclusion that it was LOBase not mysql who is causing this issue.

So I tried adding the field ‘created’ to the Table Control, thus allowing me to set ‘input required’ to no, but this doesn’t seem to have the desired effect.

This application always worked as it should, until yesterday.
I might have done an update since, although I have the impression I’m still at the same LO version (currently

Am I missing something ?


You must have updated your LO version. It appears the problem you are experiencing is the result of a bug fix in v6.1.2.1.

See my answer in this post → LibreOffice 6.1.2 Base value field problem.