Error loading BASIC of document (dialog.xlb, script.xlb)

Upgraded from Ubuntu 10 tot 11.10 recently, and since then having some issues. Running 3.4.4 on Lenovo X201 laptop, using Gnome Classic.

Every time I open a document I get two error messages:
Error loading BASIC of document
file: ~/.libreoffice/3/user/basic/Standard/script.xlb/:
General Error.
General input/output error.

The second one exactly the same, but with another path.

When I check out the path I find both script and dialog files but with an .xlc extension instead of .xlb - already created empty documents named script.xlb and dialog.xlb, alas to no avail it seems.

Any help welcome!

Similar to Error(script.xlb) after updating to version - does @manj_k 's solution work for you?

Same error for me, but a few years later and redhat centos 3.10, libreoffice 5 64bit. If remove or change the .xlb/.xlc files then open office runs, mouse works . . but keyboard doesn’t work. . . . !?? “file://home/xxx/.libreoffice/3/user/basic/Standard/script.xlb/: General Error. General input/output error.”

All hail to tohuwawohu, who answered another issue I had with spell-check. Followed his advice to reset my user-profile, and not only the spell-chack issues I had but also this one solved straight away!

Thx tohuwawohu!

I had this problem on Windows 7. It turns out that Windows had added the extension .xls to the .xlb files in my user folder. Simply removing this extension solved the problem. NO NEED TO RESET USER PROFILE.