Formulas disappearing or shrinking in LO Writer documents

LO version: (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
OS: Windows 8


I just started using LO Writer for math notes, and I’m noticing that some of my formulas in my docs are either disappearing (formula object is still there, but it goes blank) or getting shrunk (zoomed in, can see the content of the formula, but when I try to edit, it all disappears; I can’t get the formulas back). Can’t attach images to this post, but here’s what it looks like when a formula gets shrunk: (regular view and then zoomed in). Is this a known bug? As far as I can tell, there’s no way to get the content of the formulas back, so I have to go in and retype everything.

Noticed a lot of the disappeared formulas were on lines where I had multiple formula boxes, or had other text on. So I started adding formula objects on lines by themselves, but the issue persisted.

Thanks in advance for any help!


What file format do you use to save the files?

I am having this exact same problem. It just started today - and is incredibly frustrating when you’re editing your 147 page dissertation with more than 300 equations. Some are disappearing from portions of the document that I am not working on, but luckily I have many many backups.

Build ID: Arch Linux build-2

I just wanted to say that I am experiencing this too! I’m not too sure, but I think it started with a document that I was editing in LibreOffice 4.2.something (for Windows), and I now have the issue in (Debian’s) LibreOffice 3.5.4!

I suspect the file is being corrupted, rather than the office suit misinterpreting the file, if that makes sense.

(I’m use LibreOffice 5, O.S: Debian). The problem is when write large formula, and you see something like:

Then, you can solve that problem, moving the “picture” of the formula:

I have noticed that this issue is nearly 10 years old and, in 2022, it is still occurring with the latest version of LO. Why is this? The fact that the Formula cannot be integrated into Writer is a serious deficiency when so many students and researchers use and benefit from LO. Even when equations are saved in their own file, when they are imported into a document any subsequent Save results in quite random appearance of the said formulae.

@Brownbear: the issue is highly dependent on the save format of the document. and your formatting strategy. Avoid .doc(x) which need translation/conversion on load and save, causing a huge loss of information and formatting; always work in native .odt format. Second possible cause is the use (abuse?) of direct formatting which puts a big stress in Writer. Formulas automatically receive Formula frame style. If you tweaked the style (intentionally or inadvertently), you experience mishaps.

As always with advanced Writer features, you must learn the founding principles of styles (and not only paragraph styles, the most obvious ones) and correctly understand their effects. Styles are an absolute necessity as soon as your document is more then 2-page long or is frequently reviewed and updated.

1 Like

So let me tell you all this:
This problem used to be many years ago on OOffice and it somehow migrated to LO during the fork.
It’s a annoyance, mostly…
I was asked to install LO 4.4 which probably uses a newer and different way of managing formulas, and probably fixed it.
However, I did return to the native version of my distro (Mint 17.1- Rebbeca, LO 4.2), because LO 4.4 would crush too much to my taste, and I never had the chance to really find out if the problem occurs on it as well.
Just to be on the safe side: In case this problem returns to anyone else I uploaded two files that this happened to them, one after deleting a character that was after the formula box and the second one happened after reopening a saved file.
Am still not sure what causes it, but maybe these two files can help:

First file

Second file

Same for me, in RHEL, Arch, and now in OpenSUSE. Libreoffice versions 4.x, 5.x, and 6.x.
If this gets to the developers, please try and type in a few formulas, then some test text then some more formulas. After about 3-5 mins you’ll experience this effect of the formula getting shrink-ed and then when you want to edit it, it clears itself.

The best way to “work” with this problem is to do a Ctrl+A and a Ctrl+C (of the formula) after each new/edited formula. This will allow to easily restore the contents of the formula. This would reduce the number of times you have to retype the formulas.

I’m editing over 300 formulas in my reports and it becomes very frustrating. The best way forward seems like going for TeX and try and combine it with libre-office.

I need an explanation:
you’re saying that as soon as you see a formula had disappeared\changed its size, you just move the object and it returns to its original form?