Função procv

Saudações
Estou com dificuldade com a função procv, em uma planilha tenho que colocar um numero numa célula e ao lado dessa célula devo ser preenchida com o nome desse produto, para isso criei uma planilha (no mesmo documento) contendo o número e a descrição do produto.
Segue a função que eu fiz:
=PROCV(B3;$banco_dados.A$1:$banco_dados.B$540;2)

em alguns casos ele pega certinho o nome do produto, mas na maioria das vezes a célula fica com o valor: #N/DISP ou
com o nome do produto não correspondente ao numero informado
alguém pode me dizer onde estou errando?
Estou anexando uma planilha como exemploSem título 1.ods

Saudações novamente, eu consegui resolver o meu problema, a resposta consegui desse fórum:
https://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=32190

Obrigado pela atenção e caso alguém tenha essa mesma dificuldade, a função deveria ser: =PROCV(B3;$banco_dados.A$1:$banco_dados.B$540;2;0) só esqueci do ultimo parâmetro

Jaisson, uma dica, quando estiver usando a função PROCV ou H, de um nome para a área onde esta o banco de dados, no seu exemplo: $banco_dados.A$1:$banco_dados.B$540 nomeei por exemplo: dadosmeu ai a formula ficaria: =PROCV(B3;dadosmeu.B$540;2;0), acredito que fica mais fácil se tiver que procurar algum erro, e não corre o risco de esquecer o “$”.

Olá, eu tinha o mesmo problema. Corrigi de forma simples, preenchendo o último campo da função. Acredito que ira funcionar pra vc ou pra quem tiver o mesmo problema.

Solução: =PROCV(B3;$banco_dados.A$1:$banco_dados.B$540;2;"preencha esse campo"_)

Preencha o último campo da função que é referente a “crescência” dos dados (ordem de classificação). Coloque zero, mas não deixe em branco, caso a ordem dos dados de referência não sejam importantes.