Grammar / spell check not catching repeated words

Using Language Tool 2.8. Ran through a document and found repeated words (‘was was’). Ran the spell check. Nothing. Just typed ‘The cat sat sat on the mat.’ Ran spell check. Still not catching it.

Tried to remove Language Tool and then install it. Attempts to do this results in the error message:

( { { { Message = “Cannot detect media-type: file:///C:/Users/Stephen/AppData/Roaming/LibreOffice/4/user/uno_packages/cache/uno_packages/lu1apyo6.tmp_/LanguageTool-2.8.oxt”, Context = ( @6ae8900 } }, ArgumentPosition = (short) -1 }

Attempts to add it again from the .oxt file results in the error message:

Could not create Java implementation loader

Any advice appreciated.

Is this still an issue in 2019?

Maybe check if the word duplication checkbox is checked ->Preferences → Language Settings → English Sentence Checking → Grammar checking → Word duplication. If not select it click apply and okay. That should do it. In my case, it was selected, so I toggled it uncheck apply then checked it and apply OK then duplicated words got underlined with a blue zigzag line.

If it was helpful to you please check the checkmark on the left.