Hatching for cells not found in Calc 5.0.4

Want to cross-hatch a range of cells in Calc. Docs for ver. 3 say there is such a feature, but can’t find it in version 5.0.4 distributed with openSuse 42.1. Is hatching no longer available or did my install go wrong and omit some files? Where would I look to confirm?

Because of this post I have found a way to insert hatch patterns onto the draw page :

I packaged it up and it is now available, if interested, in LO Extensions - see below

Edit 2/20/2017:

It has been mentioned that the hatch is not visible when a cell background color is applied. This is true because of layering.
At this point there is no acceptable layer for hatching and cell background color together.

Edit 2/22/2017 - Release 1.1.0 with background colors available - click here.

Thanks so much for putting this extension together! It’ll really be of help.

One question, though. I’ve downloaded and added the extension, and everything works just as the instructions say, except… when I click “Insert Hatch In Selected Cells” it doesn’t insert the hatch pattern. Also, after I click “Insert…” the red text at the top of the dialog box displays “Ready for Processing” instead of “Ready for Selection.”

Any idea what might not working properly (or what I might be doing wrong?)

After clicking “Insert Hatch In Selected Cells” just below that what is displayed next to “Hatch Cells Applied =”. If the number is greater than 0 maybe the “Transparency” is set too high to easily see.
Message at top should be either “Ready for Processing” or “Please wait while request is processing”. Cell selection can only occur when dialog is closed. Will correct with next revision (minor performance change soon). If further problems please state OS & LO version.

I did a little more experimentation, and I figured out the issue.

I was trying to apply hatching to cells with background colors, and it looks like that’s a no-go. Empty cells or cells with text and no background color, no problem. But cells with background color don’t take the hatching, and adding background color to a cell that already contains hatching results in the color overriding the hatching.

In other words, I was doing it wrong. ;^)

Thanks again!

(By the bye, this was all done in Windows 10 using LibreOffice version 5.2.5.)

Thank you for the information. I will look into this. Possibly a layering situation not previously considered.

@DEKKA129 I have found the solution and will edit my answer with a temporary fix. Thank you again.

You’re very welcome.

Actually, I just tried one more thing. I added hatching to an empty cell, then added a background color (hatching disappeared, as before) and then highlighted the same cell and selected “no fill” as the new background color. The hatching was indeed still under there.

So you’re right. Rather than the background color actually overriding the hatching, it’s simply covering the hatching with a new layer. Same result when adding hatching to a cell that already has a bg color.

@DEKKA129 - Sorry but layering is not the answer. Other layers available are not acceptable for this purpose. There is, however, background color available in hatching itself. Have an idea on how to accomplish by utilizing existing background color. Will develop and post with result in day or two.

Current URL for the extension is https://extensions.libreoffice.org/extensions/hatch-patterns-for-cells

@mikekaganski - Thank You.

@Dekka129 Have posted updated extension which covers background colors. Instructions are on the page itself. Site updated since last used. Will figure out how to post actual document then. Here is the link for release 1.1.0 - click here.

@Ratslinger: one more nitpick: the root extension’s page still tells that “current” is 1.0, although shows 1.1 available. Is some action required to mark newer as current?

@mikekaganski Thanks. Already saw that. They have change extension pages all around and that is just one of the things I must re-adjust to. Wanted to get extension out quickly so bypassed a few things. Will be going back today to repair. EDIT: Tried for hours today - extension site is really messed up! Says items are changed but they are not. Valid documentation uploaded but link says it can’t find. No help, instructions. At this point garbage.

image description