Headers. What is the deal with setting up a header? Somebody please

Our MS Office expired, so i installed libre, and i’ve searched and read/tried every result for headers, and i can NOT properly setup a header. Even when i have header turned off and all page margins set to 0 it leaves a header space at the top of the page that i can’t edit, when i click it it says “Header default style”, if i click that then it adds more space and then i ‘can’ type, but i dont need all that space, All i want to do is add our company logo as well as our address and contact info, without losing 2" of space that is unused…

I’m to the point where i don’t even want the header… i just want it completely gone and ill make what looks like a header in the body, but i cant even do that because it refuses to get rid of the header… whether it’s turned off, set to 0, etc, there is a persistent, uneditable space at the top of the page… In MS office i could just type what i want in an empty header, adjust it, remove it, etc, but in libre!!! NOOOOOO

When I format page (Format->Page) and set all margins to 0 (on Page tab), and also have both Header on and Footer on unchecked (on respective tabs), I have no space at top (or anywhere else) in my LO (and on any previous that I used). What you describe seems to be severe misunderstanding what you do, and incorrect description.

If you need header, it is controlled on the same dialog. Margin (on Page tab) is space from page edge to header; when you turn header on, you have to setup two values: Height and Spacing. Height is vertical size of header’s writable area, and spacing is size between the writable area and page body. So, if you have top margin 20 mm, header height 10 mm, and spacing 5 mm, then from top the page will be organized this way: 20 mm margin + 10 mm header text + 5 mm spacing + page body. Two checkboxes (on Header tab) further control this: Use dynamic spacing and AutoFit height. If AutoFit height is set, then Height defines minimal size (instead of exact size). If both AutoFit height and Use dynamic spacing are set, then when header will grow, it will take the space from spacing (spacing will decrease → thus, page body will not move) until spacing is exhausted.

except it doesn’t, at least for me in LO No matter what values I set for header height, or what I check in this dialog, the header remains the exact same size. It doesn’t change when I paste an image into it, or when I type text into it no matter what combination of options are selected.

I have managed to get it to work by first unselecting ‘header on’ which deletes it, and then selecting it again, so yet another LO bug obviously.

@crobar: You did not describe what didn’t work for you, so impossible to tell. If it is a bug, then without a bug report with a file or clear reproducible steps, it’s also impossible to fix.

All is clearly explained in the LibreOffice User Manual

completely unhelpful


completely unhelpful

That is kind of completely unhelpful comment. The documentation (Getting Started Guide, Writer Guide, etc.) are written by other people, users, who actively participate in community. They do their best, and try to highlight what they feel needs highlighting; but of course, every piece of documentation might be improved. And one might tell “chapter X need to discuss Y more, emphasizing Z” at the very least to be useful; or even “please include my article at https://foo.bar as chapter N” - that would be awesome … but your kind of response is totally useless.

The manual doesn’t explain the bug though where you have to delete the header and then add it back in to get to work though, does it?

i agree that “i dont need all that space” and it’s not obvious how to reduce it. Here’s what i did

format → page → page tab → margins

and adjust top and bottom here