How can I get Type 1 font bitstream charter again? (I used to have it)

Up until 5.2.6, I could use Bitstream Charter font in Calc and Writer. I can’t get it in 5.3 (have tried 5.3.0, 5.3.1 & 5.3.2). If I revert to 5.2.6, Bitstream Charter is again available.
I have a Linux system. xfontsel can always find bitstream charter. Is there some way to make 5.3 use it?

A package with OTF, TTF and webfont versions of Charter can be downloaded from PracticalTypography (download links at bottom of page).

Bitstream Charter was indeed a Type1 font. I now have it as an OTF font so can use it again.

I did the conversion using tools from the afdko (Adobe Font Development Kit for OpenType). This is free and available for Linux, Mac & Windows. Home page is

The steps I used to do this follow, in case anyone else might find them helpful. If you don’t use Linux, you can skip down to the All Architectures section

Linux Architecture

If you use Slackware, go immediately to - afdko and install from there. Next install Type1_to_OTF. That’s it: you have the OTF fonts now.

For other Linux distributions: if the built kit available from the home page works for you (i.e. makeotf -h gives you the usage summary), skip on to the All Architectures section.

When I tried makeotf -h using the built kit, there was a problem with a missing shared library entry, so I had to build from source. That is what the SlackBuild does. Source is available at I suggest you visit the link above for some hints how to build it. If you download afdko.tar.gz, you can look at afdko.SlackBuild for exactly how I built it (64-bit is … unusual).

All Architectures

(But still mostly Linux)

Install afdko. Check that it works: get a command-line window and verify the operation of makeotf -h.

Download the latest release from GitHub - duncan-roe/Type1_to_OTF: Convert the standard Type1 fonts to OTF. In a command-line window, follow the instructions in the README (same as what you see when you visit the page). They are Linux commands so should work on a MAC (which is BSD Unix).

For Windows CMD.EXE: discard /tmp/.: in your home folder start with mkdir t5. From Windows Explorer, copy the files from Downloads\ into the t5 folder. I have no idea where the fonts are: the afdko has lots of documentation so perhaps you’ll find something there.

I do not know where the fonts are in either MAC or Windows systems. If you manage to use afdko on either of these, please consider posting your experience here.

I don’t have enough Karma to accept this answer. Anyone?

LibreOffice 5.3 dropped support for Adobe Type 1 fonts.
So I am guessing that your fonts are Type 1.
That is why when you go back to LO 5.2.6 the fonts work again.
Going forward you will need to use OTF or TTF fonts.

All the old BT fonts (in TTF format) are included with WordPerfect Office Pro.
Search for “WordPerfect Office X7 v10.0.0.314 Portable”
Has all the Charter BT fonts in TTF format.

You can also convert your Type 1 fonts to OTF or TTF format.
Do not know of a Linux font conversion tool.
For Windows - TransType (even has a working free trial period)
For Mac - FontXChange (don’t know about trial period)

Please click the check mark at left if this has answered your question.

I did not test them yet (if you try, let us know your results) but it seems that this fort is based on bitstream charter and is provided on otf format:

Thanks for that. It looked promising, but now I have Bistream Charter back in my font menus so didn’t pursue khartia further