How do I get Libre Office Writer to duplex print?

I have an HP Officejet Pro 8600 which supports double sided printing. It duplexes fine with AbiWord but I can’t seem to get Libre Office Writer to do it. In the print window under Properties/device I have selected that the duplexer is installed and under Properties/paper I have specified “Duplex: Long edge.” Also, when I initially set up the printer I specified that the duplexer attachment was installed. On the main print window there is no place where I can make any other selections in regards to duplex printing. Again, it works great in AbiWord so there must be something that I am missing. By the way, my operating system is Lunux Mint 15. Any help will be appreciated.

I have a similar problem using a Brother 4050 CDN. When I go to print, the Properties button is “grayed out” under the “General” tab on the print dialog box. I cannot select side binding or anything. The printer driver being used is the Brother “cups” driver via USB. I can duplex print with all of my other apps. Am wanting to migrate to Libre Office from Neooffice for mac, but this feature is a must for me.

I have the same problem with LibreOffice under Ubuntu 13.1 with my new OfficeJet Pro 8600, even after I have updated to HPLIP 3.14.3.
When I select “File > Printer Settings > Properties > Device > Duplexer Installed” it shows “Not Installed” and allows me to select “Installed.”
When I repeat the above commands, it again shows “Not Installed.”

Please, have a look at this thread, in which I present a working alternative: I CANNOT DUPLEX PRINT IN LIBRE OFFICE WITH MY OKI MC860 MFP. I THINK IT IS A SOFTWARE ISSUE MAYBE?

Does my answer here help?

Your suggestion worked for me on LibreOffice Writer version, compilation id, with HP Officejet Pro 8000. Thanks.

I have Ubuntu 13.10 w/ Libreoffice, an HP 6520 and HPLIP v 3.14.4. After selecting file/print/properties, in the new window the option for “Duplex” shows “Off”. If I change that to “Long-Edge”, then “OK”, and then select “Properties” again, “Duplex” shows “Off” again. However, if I change “Off” to “ignore”, then “OK”, and then select “Properties” again, now “Duplex” shows “Long Edge” and the printer prints on both sides!

Skyhawks workaround(above) is good and simple. I have HP 8620 and ubuntu 14.4, and had the identical problem - you set ´duplex and ´long-edge’in the print box but it immediately reverts to non-duplex.
Just to clarify, in case it is different on different set-ups, this is what worked for me:- You just set the paper to ´A4 AutoDuplex´ ( ordinary A4 setting seems to work also). Then you set the duplex choice to ´ígnore´( instead of ĺong edge´. Ok it, reopen it, and hey presto, it now says Long edge

Nota Bene: I have found that if you just reopen the properties box a second time, the settings will revert to non-duplex. Same thing if you alter any other setting - so set duplex last thing before printing!


Changing the duplex choice to “ignore” worked for me and it reverted as well just as for Walloonvic.

Thanks for this work around. The other one, printing to a pdf and than printing the pdf worked as well but my pdf viewer printed agonizingly slowly.