How to get rid of hyperlink underlines in doc files

when i edit or save a doc file the links become underlined and sometimes underline sentences/words around them. is there any way to get rid of auto underlining hyperlinks permanently instead of having to manually remove the underlines myself?

@Heroitus : You may mark one of the answers as correct if it was successful in answering your question.

Check LibreOffice help for Turning off automatic recognition under Hyperlinks.

Or on the menu choose Tools/Autocorrect Options and unclick the URL Recognition on the Options tab page.

To remove all hyperlinks in a document, select all (ctrl-A), right-click to bring up a context menu and choose Remove Hyperlink.

If you just want to remove the underline but retain hyperlink functionality, edit the character style for Internet Link. You can probably do this in your default template, but I did not try that.

If it is just the appearance that bothers you, you can also just modify the character styles for Internet Link and visited Internet Link

This is was what I was looking for